Page MenuHome

by hitting [Alt]+[F3] + [ENTER] twice, screencast cursor does not disapear after stop capturing
Closed, ResolvedPublic

Description

--- Operating System, Graphics card ---
windows 64 SP1 64bit,

--- Blender version with error, and version that worked ---
blender-2.66-windows64.7z - with issue

--- Short description of error ---
i guess, this is a very low priority issue. i never used that blender feature and i used it today only for curiosity.
after starting that screen-cast feature, i clicked [Alt]+[F3] and accepted again by accidentally, because i was not reading and thought it is like toggling it on/off - i didn't realized that there is a button to stop capture.
then, after clicking the stop Capture button, the screen-cast cursor did not disappear anymore...

to me, it looks like a counter to release the screencast cursor will increment by every starting screencast, but only decement once by clicking the stop capture button - and than the button is gone - so the release counter will never reach its full released state again. (visibility logic for stop capture button seems to be a different to the visibility logic of screencast cursor)

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
no .blend file, sorry - i can only attach a short video

1. hit [Alt] + [F3] + [ENTER]
2. hit [Alt] + [F3] + [ENTER] again
3. click [(x) Capture] button in the headline to stop screencast capturing.
4. the screencast cursor is still visible.

Details

Type
Bug

Event Timeline

Will check this today.

Took a bit longer, was busy. But fix is in svn!

Ton Roosendaal (ton) closed this task as Resolved.Mar 1 2013, 7:01 PM

I still have this exact same issue.