Page MenuHome

rigid objects not resetting original properly after running a simulation.
Closed, ResolvedPublic

Description

--- Operating System, Graphics card ---


--- Blender version with error, and version that worked ---


--- Short description of error ---


--- Steps for others to reproduce the error (preferably based on attached .blend file) ---Using the Rigid Body Tools, if you play a simulation multiple times, the items start freezing in place and don't always start back in the original origin. At times the objects when resetting the timeline to 1, will already be in a position as if they've already fallen, then if you click to frame 2, the objects go back to their original position. This is addition to the objects staying in place even after the run the simulation and during further simulations. Instead of certain objects returning to their original origin, they stay at the last resting position from the previous ran simulation. I saved a file starting at the point in frame 1 where the objects should actually be in the air, but instead are all at the bottom colliding with the plain.


Details

Type
Bug

Event Timeline

The freezing of the objects can also be seen on blender cookie's Rigid body overview.

http://www.youtube.com/watch?v=rgjvgn9Xm20&list=UU9VayT7q3pQ7tdF-TG4Q0yQ&index=5

At around the 4:50 mark, you can see two blocks being stuck at the bottom of the simulation, even though the simulation was reset. Thanks for looking into this. You guys are awesome.

Thanks for the report.
Don't forget to mention what operating system you're using.

I heard others having this problem as well, unfortunately I cannot reproduce it here.

Sorry bud, I'm using window 7 64 bit.

I noticed that if I change the mass while the simulation is playing, it sometimes, but not always, ends up sticking to the ground. I had to keep the sim playing and while it was, changed the mass a few times, then the problem occurred. It's strange. I just repeated it with a new file, but when I save it, the boxes just stay at the bottom like that was their original starting position.

I made a video of what I'm experiencing. video of what I'm experiencing. The file I've included is saved at the end of the simulation so is the one from the video.

http://www.youtube.com/watch?v=r9DgzNhlAFc&feature=youtu.be

I can also confirm this is problematic on my Macbook as well.

Thanks for your contributions Sergej!

Quck question: do you have "Rotate Around Selection" enabled in the user preferences?

Sergej Reich (sergof) closed this task as Resolved.Feb 25 2013, 11:37 PM

Is there a download link for this build or shall I wait it out?

Thanks again for you help Sergej!

You can get builds here: http://builder.blender.org/download/
Just make sure the revision number is greater or equal to 54862, might have to wait a while (shouldn't be too long).

It should also be included in the official 2.66a release next week.