Altering keymap cannot enable ndof Free Fly Mode
Closed, InvalidPublic

Description

Relates to: T34336

Linux x64, 9600gt

Fail 2.66.0r54806
Working 2.65a

Cannot not enable 'free fly' mode simply by the changing of keymaps.
The only way to get translational motion is to assign a modifier key to it, or assign a modifier to rotation so that translation becomes the default no-modifier mode.

If set to need no modifier, each of the options, when active, overrides the options below it.

NDOF Orbit View with Zoom
NDOF Orbit View
NDOF Pan View
NDOF Move View

The NDOF Move View (view3d.ndof_all) implies rotation -and- translation (all) by itself, but only performs rotation when selected.

Many of us requested free-fly capability from the very beginning of Mike's coding, and without the recently added ability to 'rotate/zoom around selection' it was certainly challenging (even painful), to veteran ndof users. But with this capability implemented it should be completely intuitive. At the very least, free-fly should be an option which can be toggled, or an option to be enabled during build.

Details

Type
Bug

I can set "view3d.ndof_all" to work fine as default, just make the other option then use modifier keys. You cannot set everything to work together without modifiers.

Doing that makes it work precisely as in 2.64 and 2.65. Was confirmed by others too.

A rotate around selection will by definition not work for free fly. It just keeps the pivot fixed then.

See attachment for screenie of the settings I used.

2-3 months ago I was getting very annoyed with so many bug reports in tracker for NDoF, nobody is maintaining it here, so i just tried to help out. The main complaint was that in 2.64 this 'free fly' mode was added, which was perceived as very useless for modeling in 3d. For non-expert NDoF users like me it felt like drunk driving :)

Based on reviews with a patch coder, I decided to bring back the default as it was (before 2.64) and make free fly an option you can simply set back.
I also added "around selection" for NDoF, but this cannot work for free flying mode.

Further work on this device in Blender is stalled, until we can find someone who maintains it actively... I know there are ways you can manipulate views much nicer than we do now.

Ton Roosendaal (ton) closed this task as Invalid.Feb 25 2013, 5:38 PM

Screenshot? :)

Based on this information, if you have 'rotate/zoom around selection' enabled, it will override the translational movement when using the view3d.ndof_all setting.
Darn...

If we can get both of those working together, cake can be had and eaten.

Putting the view pivot on selection for ndof is a new feature for 2.66. So just disable this, and you still get things to work as usual.

It's a logical contradiction to want both "free fly" and "keep viewpivot on selected". At least for our code, because "free fly" just moves the view pivot around.

In the release note it says:
The previous default (free fly mode) is now behind modifier keys SHIFT+CTRL. Users can swap this default in our keymaps.

Could you please tell me how to set the settings to free fly mode? which keymaps exactly? I tried different combinations with: view3d.ndof_orbit_zoom, view3d.ndof_orbit, view3d.ndof_pan, view3d.ndof_all, but can't figure it out. I have rotate around selection and zoom to mouse position disabled.

view3d.ndof_all is the old method, as used for 2.64 and 2.65,