Page MenuHome

Blender Crashes on toggling modes, dynatopo sculpt/object mode.
Closed, ResolvedPublic

Description

Tested on:
Windows xp 32 bit, using release 2.66 and trunk revision 54919
Ubuntu 12.04 (precise) 32-bit, using release 2.66 and trunk revision 54898

Start in the default setup/factory settings, select the cube, then go into sculpt mode and enable dynatopo, draw for about 1-5 secs. Now toggle back to object mode(without disabling dynatopo) and then press ctrl-z twice (i.E. undo), Then switch back to object mode once again for crash.

Details

Type
Bug

Event Timeline

Works ok for me. In 2.66 release, and in current svn... (64 bits, OSX). It goes back into sculpt mode for me.
However, I do get one undo step where the cube draws without any subdivision, further undo steps show subdivisions again.

More testing needed - rule out something in your system, was this Win XP and Ubuntu test both on same computer? Which graphics card?

Win7 64 blender 2.66 r54834 64bit
Same behaviors as described by reporter and Ton. Crash respectively coming back to subdidivided cube without crashing then.
Here a GeForce GTX 550Ti with driver version 306.97.

It's two different computers.
The xp has a Nivida gt 400, driver version 314.07
The Ubuntu I'm not sure what type of video card..probably integrated.

Video link to the steps it takes to crash.
http://www.youtube.com/watch?v=MMCTVCaf_xY

Just tested on another computer:
Windows Vista 32 bit
geforce 6100 nForce 405
drivers 306.97

Will be able to access some 64 bit computers later, to test and see if it is limited to 32 bit platforms.

I just tested on a Mac
using blender 2.66
OS X 10.8.2
NVIDIA GeForce GTX 675MX
16 GB 1600 MHz DDR3

And it still crashes....

Confirmed here, Windows 7 x64, SVN 54991.

Yep that fixed it, thanks!

However, I can still get it to crash with toggling between modes sometimes (you have toggle between modes/and sculpt a lot before you get a crash), I have not found any re-produceable steps so far...

This has not been successfully fixed. Like the official release, r55007 causes an instant crash every time I enable dynatopo on my school laptop. HP/Compaq nc6320 (Windows 7 Enterprise, 32 bit - Intel CPU1.83Ghz, 2.5 Gb RAM).

Crash dumped as:
# Blender 2.66 (sub 0), Revision: 55007
bpy.ops.sculpt.sculptmode_toggle() # Operator

Update: Crash fixed with newer graphics driver download.

Well I found reprodaceable steps that makes blender crash and it's pretty similar to what you had to do to make it crash in the orginal bug report.
This has been tested on:
Ubuntu
Windows 7
Windows xp
Mac osx
and each one of those is a different computer.

Here's the new steps to make it crash:

Enter sculpt mode
enable dynamic topology
draw a line on cube
switch to object mode
undo
undo
switch back to object mode (since we were put back in sculpt mode when we did the undos)
undo
undo
undo

and then crash

Edit: Forgot to mention that my latest round of testing was done on blender 2.66a