Page MenuHome

cut looped (red) connection crash
Closed, InvalidPublic

Description

--- Operating System, Graphics card ---
Win7 x64 Lenovo Y580 using Intel HD4000

--- Blender version with error, and version that worked --
official 2.66 and recent trunk 54991

--- Short description of error ---
when i accidently created a loop inside a compositor and than cut it with ctrl+left mouse drag blender crash
i wouldnt crash when unplugging such a connection

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
FACTORY SETTINGS:
Just go to node editor.
- use Nodes.
- add 2 mix node into node tree
- feed second mix node output to the first mix node input creating a loop visualized as red connection
- cut red connection with ctrl+left mouse drag
- CRASH
- instead of cutting just unplug red connection to avoid crash


Details

Type
Bug

Event Timeline

No crash here with SVN 54991, Windows 7 x64.

Maybe I did something wrong, in such cases also attach an example blend file, so we only need to cut the line. :)

attached file: just cut the red connection

No crash here after cutting the red line. Windows 7 x64, SVN 54991.
So same OS, same Revision. Not sure why it works for me but not for you.

Maybe Jeroen can check on a Linux system? Assigning to him.

No crashes in 2.66 release or svn debug (OSX)

No crash here either, tested with r55001, valgrind also gives no warnings.

4 tests by 4 developers, no one could reproduce it.

@Czarek: Can you test this on another computer? Or maybe update GPU drivers?

No crash here linux64 2.66 and trunk release build.

During development there were some crashes here (april-june 2012) but has been solved. I will close the report for now. there is also a way (but have never reproduced it) that a specific trunk version created wrong links, that made a crash but that is not with a recent version. Please open again when it can be reproduced.

Thanks for the report!

Jeroen Bakker (jbakker) closed this task as Invalid.Mar 4 2013, 7:04 PM

Ehh Firstly SORRY i had two beers and ... never mind :)

Blender Crashes when doing reroute (Shift+LMB drag) on looped connections not cutting.


Confirmed and fixed in r55047, thanks for reporting!