Page MenuHome

Copy/Paste an empty across Blender Instances Hangs
Closed, ResolvedPublic

Description

--- Operating System, Graphics card ---

Windows 7
--- Blender version with error, and version that worked ---

2.66
--- Short description of error ---
Copy/Paste a complex hierarchical empty hangs the UI

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
Select the "Player" empty from the attached .blend, mouse over to the editor window, press CTRL+C to copy the selection to buffer. It will hang.

Details

Type
Bug

Event Timeline

Will investigate it.

Fix goes to svn, thanks for finding this! It was entering an eternal loop yes.

Note that because of all linkage, constraints etc etc, the pasted result inserts the complete scene with nearly everything.
It uses the same functionality as an append from file.

Ton Roosendaal (ton) closed this task as Resolved.Mar 5 2013, 12:19 PM