Page MenuHome

Sketching bones created bones with 0 radius for envelope
Closed, ArchivedPublic

Description

--- Operating System, Graphics card ---
Windows 7 64bits, GTX560

--- Blender version with error, and version that worked ---
2.66 official

--- Short description of error ---
If you use the Skeleton sketching tool the operation create a lot of bones with 0 in radius, And you must change the radius in each bones because you cannot scale something with 0 in the value.

I don't know if it's normal. But I have asked in blender artistat and nobody answered to the thread.

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
only make the same that I write in the description. You can see my result in the blend that I upload.

Details

Type
To Do

Event Timeline

Never used this tool, but it indeed seems to be not setting envelopes. I also get memory errors... seems to be old bugs in this system.

Bone envelopes are quite uncommon these days though. Everyone uses weight groups, which is much more precise for armatures.

Just a few notes from my investigations of this issue:
1) iter->size (in subdivideArcBy()) seems to always be "effectively zero", but is actually some really really small value (e.g. 0.00000000000001). Replacing the "iter->size > 0" checks to use FLT_EPSILON instead of 0 seems to solve the problem of bones getting wrong envelope size

2) iter->size actually never gets set to anything meaningful. That is, in most places, the size value is just copied from some other place.
It seems that the only case where size gets set to anything is when some specific volume/snapping settings are enabled, in which case it is taken to be the size difference between two matching depth points AFAICT. But, this is almost never used; even then, I've never really been able to get the volume snapping to behave even semi-reliably.

Ton- I don't use this tools because I don't make animations. But I was learning this part of the program to know all the workflow / tools and I saw the problem. I suppose that some people will use this system (I dunno) and I reported the bug. ^^


I committed the mentioned fix (r. 55105) which solves the immediate symptoms of the bug.

However, this does not address why exactly why/how those values got there in the first place. As this code is currently orphaned - i.e. no active developers actually know exactly what all of it is doing - I've noted this issue on the todo list for when someone with the time and interest in improving this system can check on it.

Joshua Leung (aligorith) closed this task as Archived.Mar 16 2013, 1:49 AM