Page MenuHome

Quick edit image buffer is saved as 8bit image
Open, NormalPublic

Description

--- Operating System, Graphics card ---
Nvidia 750gtx, Windows7 64

--- Blender version with error, and version that worked ---
2.66

--- Short description of error ---
When painting textures it is common to export the current camera buffer to an editing applicationn and bring bacvk adn reapply as project in Blender and other apps. Blender provides this functionality as "quick edit" in the texture painting panel. It is all great however the buffer seems to be saved as 8bit which renders the integrity of an highbit (16/32) images. I believe that the quick edit buffer bit depth should be saved as the original image bit depth. As of right now the fidelity of an high bit image is compromised with 8 bit image buffers.

I use Photoshop for image editing so this is not an image editing app mistake, as in that would be with Gimp since it has no support for anything else besode 8bit images.

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
Add a 32 bit image to your model for texture painting
open texturing mode
click quick edit on the texturing pane
It should open up your editing application for quick painting.

You can also try the blend file I attached.

Details

Type
To Do

Event Timeline

Btw sorry about the typos, I realized them after the post .

I don't know this feature, and wouldn't know how to use it even. But for me it seems to be just a snapshot of the 3d viewport, which is 3x8 bits color by default.

Why would you expect viewports to be in 3x32 bits color?

Ton,

First of all it is a color fidelity problem. When you are working in 32 bits you would want all your colors stay truly be 32 bits during any operation. Presume that you are working on a higres high bit displacement(which is single channel high bit) / color map, and it is a float 32 bit linear image in Blender. When you take that projection to Photoshop paint it and bring back and reapply in projection mode ( the quick edit thing) in texture paint mode , you might run into color management or run into color fidelity problems. You just loose some of the information you might have painted in Blender during that back and forth. For game work that is perfectly fine, but for movie work that is a pipeline problem which is why I brought it up.

It is great that we have that option.But it is a tricky thing because people might not realize that they might loose color values between these operations.

cheers

k

This can be supported, Ill check on it.

Note:

The intention of this feature is that you paint into a new layer and hide the existing image before saving.
This way the pixels from blender are mainly a reference, if you want you can save the image as 32bit-per-channel image, however it may be better to add some option in blender so you dont have to manually change the channel depth each time.

Would be nice to support, but strictly speaking not a bug. Moving to TODO now http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Tools#Painting

Thanks for the report anyway!

Sergey Sharybin (sergey) closed this task as Archived.May 29 2014, 10:53 AM

Let me add some notes, to may be rise priority a bit.

First of all. Textures can be not only 8 bit but 16 bit integer. In that case 8bit export to external app probably not so critical. But if texture 16/32bit float applying 8bit back from Photoshop or other, create a lot of issues. And good example was posted before.
This external app texturing feature one of huge blender benefits comparing to ZBrush or other. Alpha channel support allow fix 3D scan based textures without affecting correct parts of scanned texture.

Another problem is PNG itself. It Extremely slow. It have best compression ratio but extremely slower on saving or open. Will be better add choice using PNG, Tiff, PSD, EXR to external painting support.