Page MenuHome

game engine node material bug with 2 vertex color channels
Closed, ArchivedPublic

Description

Category: Rendering

--- Operating System, Graphics card ---
winxp, gef430

--- Blender version with error, and version that worked ---
works: never
buggy: 2.66a

--- Short description of error ---
game engine node material bug with 2 vertex color channels

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
1. load attached blend
2. press P to run game engine: only one vertex color channel visible in game engine (it works in the viewport)

the node system is simple: it mixes the two vertex color channels by 50%

Details

Type
Bug

Event Timeline

Moved from Blender 2.6 Bug Tracker to Game Engine

Duplicate report: https://projects.blender.org/tracker/index.php?func=detail&aid=31385&group_id=9&atid=306
Keeping this one since it has more information and a clearer title.

Duplicate report: https://projects.blender.org/tracker/index.php?func=detail&aid=19291&group_id=9&atid=306
Keeping this one to separate the above report into two reports.

I have and object with 5 different materials/textures and I want to use different vertex layer to "paint" this materials in that large object. In 3D view works (GLSL activeted), but when I start the game it seems that blender GE only use the first vertex color layer.

here my file: http://drive.lluc3d.com/public.php?service=files&token=1a183667548c261b31b3c44fc181b7d1e5d6ec7e&file=/bug_colorvertex_BGE.rar

Is this fixed?
A flexible 5 texture terrain base With 2 uv layers would make for a single draw called terrain that could have quite a bit of detail.

As far as I know, this is still a problem. You are welcome to try to reproduce the bug on a recent build and report your findings here.

Not sure whether for the same reason but the workaround I posted here: https://developer.blender.org/T33730 work in this case too.

To summarize, just add a modifier like Subsurf (even with zero subdivisions).

I hope this helps.

Aaron Carlisle (Blendify) closed this task as Archived.Jun 29 2019, 2:12 AM
Aaron Carlisle (Blendify) claimed this task.