Page MenuHome

Blender 's fullscreen vs OSX fullscreen conflict
Closed, ResolvedPublic

Description

--- Operating System, Graphics card ---
OS X 10.8.3, NVIDIA GeForce 320M 256 MB

--- Blender version with error, and version that worked ---
Blender 2.67 RC, previous versions didn't have OS X' fullscreen

--- Short description of error ---
Newly added OSX fullscreen support in Blender is very cool, but sadly it is in conflict with Blender's built-in fullscreen.

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---

I've attached screenshots depicting each step:

1. Turn on OSX fullscreen in Blender.
2. There is a top menu accesible while mouse cursor is at the top of the screen - you can turn off there the fullscreen mode. (Don't use it yet, just check if it's there)
3. Toggle Blender's fullscreen mode (Alt+F11) on.
4. Now toggle Blender's fullscreen mode (Alt+F11) off.
5. You can't turn off OSX fullscreen anymore. Quiting Blender is the only way to go.

Possible solutions:
1. Removing blender's Toggle Fullscreen option under OSX
2. Making both options work the same.

I see one advantage of Blender's fullscreen against OSX fullscreen - it is faster. Blender goes fullscreen instantly, while using OSX button it is animated. So maybe that's good thing that tehy are both in Blender. But they shouldn't be conflicted.

Details

Type
Bug

Event Timeline

Yes you cannot use both at the same time, you need to pick one... currently there's no provision in Blender to prevent this.
I might remove it for the release then.

Fix in svn, thanks for the report. Made it impossible to enable both at the same time now.

The main reason to keep supporting the old fullscreen is because the new Lion fullscreen does not work with multiple monitors, it will just give black screens on the other monitors. This is a limitation of OS X, you can find many complaints about this online. Makes it all a bit confusing.

Brecht Van Lommel (brecht) closed this task as Resolved.May 6 2013, 3:39 PM

I can't enable old Fullscreen, no matter what i do! alt+F11 and Menu Window - Toggle Fullscreen both do native stupid osx Fullscreen.

How can i get the old Fullscreen??

And can't we just disable Native Fullscreen altogether? Or maybe set alt+F11 and Menu entry to do old Fullscreen - for new Fullscreen people could use the Osx Fullscreen button in Windowbar top right.