Page MenuHome

Rendering dupligroup objects that have modifiers using external object offsets doesn't work right.
Closed, ArchivedPublic

Description


--- Blender version with error, and version that worked ---
At least from 2.62 to r57083

--- Short description of error ---
Rendering a dupligroup object behaves incorrectly, when the object has modifier that uses external object as offset, such as array. The object renders wrong in blender internal, and in cycles if the original object and the dupli object are on different layer. The results of array in the renders work on the relation between the dupli object and original array offset object, which are often in totally different places, whereas in the viewport it behaves as expected, duplicating the object as it looks in the 3d space. Tested also with mirror modifier using empty as mirror object to the same effect

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---

In the attached file render, and note how the dupligroup instance doesn't render like it looks like in the 3d viewport. Change to cycles and move the camera and dupli object on another layer and note that the render doesn't work.

Details

Type
To Do

Event Timeline

Our duplicator system can be weirdo... the error is actually because the empty controller is not part of the group. Just add it to the group to make things work.

What happens on render is it uses the original empty location for the modifier... renders re-evaluate the full animation system and stores stuff locally.

How this *should* work is a bit undefined... I would think the bug is in the 3d viewport even, not for render. With a big "dependency graph" recode underway, I will store your report and the test blend in our wiki list, to use as test reference this summer.

http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Animation#Dependency_Graph

Thanks!

Ton Roosendaal (ton) closed this task as Archived.Jun 1 2013, 5:54 PM