Page MenuHome

VSE does not display properly when in "Both" mode
Closed, ResolvedPublic

Description

Duplicates: T36457

--- Operating System, Graphics card ---
Windows 7, no graphics card (the issue is not related to either factor)


--- Blender version with error, and version that worked ---

All 2.5x and later versions have this behavioral problem.


--- Short description of error ---
When VSE is set to "Both" view (mode), Blender should split the window and show both views ("Sequencer" and "Preview") simultaneously.

Instead, it shows the "Sequencer" mode (view) ONLY. To a new user, this is confusing (looks like the command failed).

Further, the user is expected to drag a tiny + button downward from the right-hand-top corner of the window.
Here, another unexpected thing happens: As soon as he drags the button, the "preview" panel springs open and occupies the WHOLE window.
The user cannot see the "preview" view at all.

(Expected behavior: When the user drags the + button, the dividing line between the "Sequencer" and "Preview" views would be dragged smoothly, so the user can set the panes for both views exactly as he likes.)

Instead, Blender has a strange way to make the "Sequencer" view visible: The user has to grab the lower wedge of the window and pull it down.
As the entire window re-sizes, the "Sequencer" view opens gradually.
This also is very odd behavior.

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---


Details

Type
Bug

Event Timeline

My guess is that your window is just really tiny and default size for preview area makes it overflow the area and hence it's collapsing. Dragging (+) restores to default area size, afair.

This is description about why it happens.

Ton, could you please check on this report? Thanks!

No I actually made the VSE full size (CTRL+UpArrow) and then did this. Enclosing a video (please pause it when needed - I am trying to keep the video size small).

Hi Sergey,

I am not sure whether I had explained clearly; so adding a little clarification:

In my experiment, I had (a) maximized Blender window to full-screen and then (b)maximized VSE (CTRL+UpArrow) to take up full screen.
Even then the result is as described in my report. That means the window is not collapsing as you inferred.

Later, for capturing the video I made the window size smaller (to reduce the file size).
The result is same as before; which means the window size does not influence this behavior.

Desired behavior:
In "Both" mode, VSE window should be split equally and both "Preview" (at top) and "Sequencer" (at bottom) should be displayed.
By default, both panes should have the same height. (The user can always drag the border between them in case he wants a different size.)

[sorry the last post was not fully composed. Please ignore it, and read this one.]

I tried a variation of the earlier experiment and found more peculiar behavior:

I set a VSE window to "Both" mode, the entire VSE window switched to "Sequencer" mode.
I dragged the tiny + button only a little, and the entire VSE window switched to "Preview" mode (not split screen).
Up to this point, the script follows the old bug. But here, I tried a variation: I pressed CTRL+UpArrow.
The VSE window maximizes, and shows the split screen.
But if I toggle it back to its original size, the split screen vanishes, to be replaced by the "Preview" mode.

This is shown in the second video I uploaded.

I do not know the current status of this bug, but for those who prefer text to video, here is a complete set of steps to reproduce the two issues demonstrated in attachment VSE.webm.
1. Load the factory settings.
2. Switch to Video Sequence Editor. VSE opens in the sequencer view.
3. Switch VSE to the preview view.
4. Switch VSE to the “both” view. This shows one issue:
* Actual behavior: The entire VSE is filled by the sequencer pane.
* Expected behavior: VSE should be split between the preview pane and the sequencer pane, both visible.
5. To move the border between the two panes, start dragging the “+” icon hanging down from the top at the top-right corner of VSE downward. This shows the other issue:
* Actual behavior: As soon as you start dragging, the entire VSE is filled by the preview pane.
* Expected behavior: The dragging just a little bit should move the border just a little bit.

Reproduced with Blender 2.67b 64-bit (official binary) and r57344 64-bit (http://builder.blender.org/download/blender-2.67-r57344-win64.zip), both on Windows 7 64-bit.

I think the issues demonstrated in attachment VSE2.webm are the same as the ones demonstrated in VSE.webm.

Ok, I am looking into the code on this one.
So far I found the routines in the Sequencer code but they reference higher up code. I'm moving outside the sequencer code looking for the "SEQUENCER_OT_view_toggle" code that the UI/button call triggers.

As I mentioned, we can post help/questions here or I will bring it up in dev chat if I get stuck or take too much time.
If anyone else is spending time on this, please let me know. Thanks.

I'm making progress. I got it to partially work correctly. There's still more work to be done.

The areas of code have been identified involving all this behavior. There are ~3-4 issues. I am still deciphering the window management code and the variables/flags used so answers are coming in segments.

One issue is actually a "works as intended" issue but it is backwards from what is expected. In actuality it works fine when you consider that.
While in sequencer view, if you click on the both button a '+' will show up. Click and hold on the plus and DRAG UP, NOT DOWN and the preview window will become visible and as you drag up the sequencer will scale up in size as the preview window scales down in size.

So it is backwards from the usual or expected behavior of dragging the "+" down to reveal the preview window. But still, it works as coded/intended. So this part is an inconsistency todo.

More to come soon.

Main issues breakdown:(using default cube scene added as a strip for testing)

When first entering the Video Editing screen the Sequencer button is depressed but the + is available as in Both mode.
Drag Down the + only works to reveal the Preview the first time if no toggle buttons were pressed and results in a preview zoomed very far out and so tiny it is unusable without zooming far in.

With the default Video Editor screen layout the logic of the Sequencer/Preview/Both buttons do unexpected changes and are inconsistent in the changes depending on what order they are clicked on.
Some combinations keep settings, some zoom to the background size, some zoom too far into the background clipping the bottom of the cube view.

Even when other areas are removed and the Sequencer area is full screen, unexpected changes occur similar to when in default layout with a smaller Sequencer area.

So it seems there are tri-logic toggling algorithm issues, zooming consistency issues, + Drag Down issues and Preview state retention issues.

NOTE: The Sequencer is the only place the UI "+" region scale code from screen_ops.c is used other than with options/tool panels as far as I can see.

The scope and fix appears to be a combination of Python UI code and C code from both the Sequencer code and the region scale code.
Ton, I would need your help in identifying flags and variables to focus debug traces/watches on to find an exact scope and fix.

I have a partial fix via changing some values during debug. Hopefully I will have a complete fix and a patch soon.

Ok, I located and verified the fix for the popping fully open when clicking on + tab for both mode bug.
I will code a patch next for it alone. The other two issues of odd toggle logic and inconsistent zoom settings should be resolved soon also.
JTa

Note for clarity:
This is not a bug but rather a works as intended behavior from a quick and dirty hack.

There are two issues. One is incorrect button toggle logic. This issue remembers previous states so it looks odd, but it works as intended. Reworking the logic requires modifying the windowing code and/or parameters, not just VSE code.

The other issue is the preview window sizing. The sizing actually works as intended in code. If you hold down the mouse button after clicking on the plus sign to reveal the preview, you can pull up and size the preview as intended. When you release the mouse button after clicking the plus sign it usually pops just barely below the header as intended by the vertical code.

This behavior is from the hack that was used from the vertical reveal code being applied to a horizontal window. I have the code identified and know where to fix it. I have the fix working in debug mode. The issue is it includes modifying the windowing code outside of the VSE code and effecting the sizing routines directly for everything else.

Merged the reports now.

Not sure why you think window code is to be modified. Will look into it but think it's doable from the sequencer's space update() callback.

The modifying window code train of thought was it would help any other horizontal show/hide issue, not just address the current one with the VSE.

Same for me, however it's using showing the preview screen instead of the sequencer screen (where it should be showing both).
Tested with 2.71 testbuild2

When I opened the same file in 2.68, It was in preview only mode. I switched to "both", and then it appeared as a sequencer with a plus icon at the top of the editor. Clicking the plus changed the entire "both" view to a preview, with no plus icon visible at the top of bottom of the editor.

gandalf3 if you take a closer look at my "Note for clarity:..." post above, there are too odd behaviors. One is the size of the window the other is the button toggle logic. The buttons sometimes use the previous size and sometimes they do not. It all depends on the order in which they are toggled. That sounds like what is happening to your file.

None of the devs have posted here directly changing any code to fix this. So unless someone has changed code for 2.71 that unintentionally changes this behavior as a side effect, I don't know why you are getting two different results in the two versions with the same file.

Please take a look at my "Note for clarity:..." post to see if that seems like what is happening. It should not be file specific, it should happen with the Sequencer and the default file the same as with any other file IMHO.

@JT Nelson (jta) That makes perfect sense now, thanks.
It does indeed happen with any file, and the behavior seems the same in 2.68/2.71 testbuild2.

I did notice one odd thing though (I'm not sure if it's already been noticed), but if you switch to "Both" after being in preview mode, there doesn't seem to be any way to get a sequencer when in "both" mode (I don't see any + icons).

Bastien Montagne (mont29) closed this task as Resolved.

Eeeeh… Was not aware of this report… I fixed this the other day (from T41323, rBf37c3dd6a672).