NLA Baking + MatchBone -- please close
Closed, ArchivedPublic

Description

Resolution: Rejected

Hey Toni - here's a patch against bf-blender CVS, not Orange, as I didn't have time to try syncing to that branch (I've not done so at all yet). If this is useful, great. If not, you should be able to work from the cut 'n pastes.

Issue with this code: I abused the strip->mode flag in the interest of getting this working quickly. I think the flag was intended to be just a toggle between Blend and Add modes, as the GUI code shows (it's a TOG type). There's no GUI access to the new mode (2=POSE_MULT=ACTSTRIPMODE_MULT), but setting the "Add" parameter to 2 when calling add_nla_block_by_name will set it.

With this patch, baking object motion into an action is triggered by pressing SHIFT-B for the active NLA strip. Doing so create the new action, adds it to NLA in the new MULT mode, unlinks any object-level IPOs from the object and clears it of having any parents. The code will pickup and Bake any kind of object-level motion, including follow-path constraints, etc, so other relationships that affect the object will have to be cleared after the bake to avoid having them applied doubly.

This is a long way from polished, but it's a very short way from working.

Patch made with cvs diff -u, as ton stated he prefers...

Details

Type
To Do