Page MenuHome

End of SequencerEntrys not set correctly
Closed, ResolvedPublic

Description

--- Operating System, Graphics card ---
Debian 6 and GeForce 210/PCIe/SSE2 with NVIDIA 295.59


--- Blender version with error, and version that worked ---
Bug found in 2.68


--- Short description of error ---
I don't think it is something that the user would notice, but in "sound.c" when a new SequencerEntry is added, the end of that entry is always set to "-1" instead of the correct value. This leads to entrys still updating even after their end was reached, wasting cpu and causing major problems with something im working on.
I attatched a patch that fixes the problem for me.

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---


Details

Type
Bug

Event Timeline

This is not a bug, but intended behavior. -1 stands for full length so that the audio systems plays the sound in it's complete length. One might think that there is no difference to setting it to the length of the sound, but FFMPEG sometimes reports a wrong estimated length and if that is to short, the sound would not be played to its full length as desired. Only when the sound length is changed by the user the length will be set to a different value that is exactly the length provided by user input.

Regarding wasting CPU cycles by having the sound updating all the time in AUD_SoftwareDevice::AUD_SoftwareHandle::update() there's only one solution: adding another sound state next to invalid, paused and playing that marks a sound as finished, I'll think about that.

Revision 59143 should fix these performance problems that you are encountering. Closing.

Joerg Mueller (nexyon) closed this task as Resolved.Aug 14 2013, 11:21 PM

Works great here on my machine.
Thanks =)