Page MenuHome

Fluid sim: parented fluid inflow object not animating properly
Closed, InvalidPublic

Description

--- Operating System, Graphics card ---
Windows 7, AMD 4870

--- Blender version with error, and version that worked ---
Fails in 2.68.0 and still in 2.69.0 r58368. Might never have worked

--- Short description of error ---
If a fluid inflow object is parented and then the parent is animated, the fluild flow seems to follow the rotation but not the location properly.

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---

.blend file is attached.

Event Timeline

This is not a bug, you simply have to enable "Export Animated Mesh" for the inflow object, in such cases…

Bastien Montagne (mont29) changed the task status from Unknown Status to Invalid.Oct 4 2013, 3:29 PM

I thought "Export Animated Mesh" was if the mesh was being animated i.e. changing shape. It might be a workaround but makes the simulation very slow.

If the inflow object itself can be animated (position, rotation) without that option there is no reason it can't be made to work when it is being moved around by its parent.

Sight… Please read the tooltip of that option, it specifically says that it is necessary to handle complex animations like armature or *parenting*.

And yes, they are reasons for tracking transformations from parent relationship being more complex than mere F-Curve animation!

Ok sorry, I should have read that more carefully.

I still think it could be made to work if only rotation and translation were involved. The rotation is working so the motion due to parenting is already partially factored.

However. since it is listed in the tooltip I guess this would have to be an enhancement. Maybe I will take a crack at it.