Page MenuHome

Camera view doesn't support continuous zoom
Closed, ResolvedPublic

Description

--- Operating System, Graphics card ---
Mac OSX - NVDIA 650

--- Blender version with error, and version that worked ---
2.69. Has never functioned properly for me.

--- Short description of error ---
When I use pinch gesture to zoom in and out, it functions properly in the 3d workspace and the image/uv editor. However, when I try the same gesture in any other window, there is not a smooth transition and it will often cause blender to freeze for a few seconds.

Here is a video that shows what I'm talking about.
http://www.youtube.com/watch?v=VvzI34wjB6s&feature=youtu.be

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
Use pinch zoom gesture in different windows and panels.

Details

Type
To Do

Event Timeline

Someone with a multi-touch OSX stuff can confirm this? Looks like some wrong (too big) factor for handling that kind of zoom in most areas…

Hi
I testeted this with a MacPro OSX 10.9.1 and MagicTrackpad and it works just as expected.
Gpu is eiher ATI 5870 or 7970, both doing zoom fine in all areas.

Jens

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.May 19 2014, 5:47 PM

@Brandon Farley (farcgs), is it still an issue for you with latest release and builds form buildbot?

Yes. I've been using the + and - to control the zoom. Pinch zoom on my Macbook Pro trackpad is still wonky on some features, such as the node editor, properties panel, timeline, and the 3d view side panels.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.May 26 2014, 7:14 PM

Merged similar report in here.

@jens verwiebe (jensverwiebe), would you have time to check on this?

I still cannot reproduce any freezing here.
Tested with magic trackpad to check pinching ....
Also haven't experienced any sluggish drawing.

Jens

I can't reproduce the horror I see in that video but there is this one thing which only happens from time to time. When I take my hand off my pen tablet, I roll my palm back softly and lift at the same time to avoid activating a gesture. However, every once in a while this will be registered by Blender as the most dramatic of movements. From the Viewport response, you'd think I had just roughly and quickly swiped my hand across the entire tablet. It's rare but I estimate that it happens maybe a couple times a month.

There are 2 things that are very weird about this.

(1) There is no way under normal circumstances for me to get the view movement functions to move that fast. At those rare time when it happens it's turbo-charged, it goes fast and far.

(2) For me to zoom in the 3D view, I have to hold Ctrl while I swipe up/down on the pen tablet. When the crazy-zoom happens as a response to my palm movement, holding Ctrl is not necessary for the zoom to take place. Only the subtle palm movement.

If the person who reported this was really ambitious about helping to solve this, is there a debugging program that he could run Blender through to capture what Blender is doing while he scales those windows?

I figured out what my problem was. I went to the Input Settings in the User Preferences, where it says "zoom style" and chose the "Dolly" option instead of "Continue." After I did that, I no longer experienced the glitch.

I'm not really sure if it's a bug actually then, maybe pinch should ignore zoom style tho. @Campbell Barton (campbellbarton), do you have strong opinion here?

Sergey Sharybin (sergey) closed this task as Archived.Oct 14 2014, 3:05 PM
Sergey Sharybin (sergey) claimed this task.

Things might be improved for pinch zoom and different zoom styles, but wouldn't really consider a bug, it's thing which belongs to TODO: http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/UserInterface#Events

Thanks for the report anyway,

Campbell Barton (campbellbarton) changed the task status from Archived to Resolved.Mar 21 2016, 5:00 AM

This is resolved in 2.77

I just tested this with the latest build (Mon Mar 21 05:02:46 2016) on my Macbook Pro. The problem still occurs within the same panels and editors as shown in the video. http://www.youtube.com/watch?v=VvzI34wjB6s&feature=youtu.be