Page MenuHome

Lineset only applied to first renderlayers only
Closed, InvalidPublic

Description

System Information
Linux 64 bit

Blender Version
Broken: Blender 2.69

if you have more than one renderlayers lineset only applied to the first one only the rest need to add manually

Exact steps for others to reproduce the error
First add several geometry, put it in different layers.
create several render layers
enable freestyle
only the first renderlayer has a lineset, the rest doesn't.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Normal priority.Nov 27 2013, 4:28 PM
Tamito Kajiyama (kjym3) closed this task as Invalid.Nov 28 2013, 1:42 AM

Many thanks for filing the problem report.

I consider the reported issue as a feature and not a bug.

The reason why the first render layer has a line set is because it will make the use of Freestyle easy for new users. The idea is to allow them to obtain a meaningful visual outcome by just enabling Freestyle. This was indeed a specific request from code reviewers when the Freestyle development branch was merged into the Blender code base.

I believe it is desirable in many cases not to have a line set for each newly created render layer, because:(1) whether Freestyle is needed in a given render layer depends on individual scene setups; (2) it is a matter of clicking the '+' button next to the list of line sets to add a new one; and (3) creating a new line set implies the creation of a new line style data block.

The last point may require some explanation. It is noted that a line style (associated to a line set) is a data block, which can be referenced (i.e., reused) by one or more line sets. When a new line set is created, a new line style is also created and linked to the new line set. Now, suppose that you have created a new line set by mistake and you want to delete it. Doing so is really easy since you just have to click the '-' button. But the line style that was linked from the deleted line set stays there until you save the file and reopen it afterwards (exactly in the same way with other data blocks such as mesh, texture, and so forth). I have seen many new Blender users asking how to delete unwanted data blocks that stay there and could not be deleted. Since the default line set associated to the first render layer is intended for new users, I would like to avoid confusing the same new users with unwanted line style data blocks.

It is definitely possible to change the present behavior and create a new line set for each newly created render layer. That is really a matter of design preference. Although I close the task for the time being, I will stay open for any further discussion in view of design revisions.