Black matcap when object located on a curve
Closed, ResolvedPublic

Description

System Information
Windows 8x64
nVidia GTX 560 1GB

Blender Version
Broken: Blender 2.69

Sorry for my English, I use the Google translator

a short video (58 seconds).
I place an object on a curve, and then the object with the applied Mattsap becomes black
https://www.youtube.com/watch?v=rfIMdqdNFtw

Blender 2.69 r60995

Brecht Van Lommel (brecht) triaged this task as "Normal" priority.Dec 1 2013, 2:52 PM
Brecht Van Lommel (brecht) changed the title from "Black Matkap when object located on the curve" to "Black matcap when object located on a curve".

I couldn't redo the problem yet on OS X. It seems in the video it works for a moment then stops working when you change the matcap, I tried this but still found no problem.

Does it show any error in the Window menu > Console?

I asked other people to check this error on their computers, but no one responded.
If you tell me what to see or where to check for error messages, I'll do it. But I do not see any error messages.
Here's a video, it's about how I noticed it, I did the caterpillar to the tank, according to this principle, and matkap became black. On other objects Matcap works perfectly.
https://www.youtube.com/watch?v=1V1D-00efxE

I can confirm this on my laptop (havent checked my workstation)
This happens on object duplication types "frames", "verts" & "faces" (so doesnt really have to be on a curve) when you _change_ the matcap and stays black even when changed back to the "original". [will try to have a look at code as well...]

my opengl specs

renderer: 'Mesa DRI Intel(R) Sandybridge Mobile '
vendor: 'Intel Open Source Technology Center'
version: '3.0 Mesa 9.2.3'

one guy with Win 7 x64 said that he's okay. He repeated an example of the video and it all works fine.
Sorry if this is a bug only on my machine

It seems we have it confirmed on two quite different configurations now, so there is most likely some sort of bug involved, like an invalid OpenGL state.

@Brecht Van Lommel (brecht), can redo the issue here. Will look into it, but maybe i'll need some tips from you.

Sergey you speak Russian?
if I understand you correctly, and if you need something from me, I'll try to help

@Axel (AxelMening) i indeed speak russian. Nothing needed from you at this point, i've tracked the issue down, but need @Brecht Van Lommel (brecht)'s advice on how to best solve the issue.

@Brecht Van Lommel (brecht), the issue is caused by GLSL used from inside of OpenGL list in function draw_dupli_objects_color. For some reason, shader doesn't work correct here on both integrated intel and nvidia optimus cards. My guess is that this happens because GLSL is being de-initialized after the object was drawn so shader can not access textures when called from the displist. And this actually applies to both matcap and regular GLSL viewport. Will submit patch which works here in a minute.

Sergey Sharybin (sergey) closed this task as "Resolved".Dec 3 2013, 5:14 PM

Closed by commit rB462751688449.