Page MenuHome

Improvement for ply import
Closed, ArchivedPublic

Description

Not so much a bug as a possible case that could be improved.

Looking into a question on stackoverflow - http://stackoverflow.com/questions/20229264/how-can-i-prepare-a-point-cloud-for-visualization-in-blender-using-meshlab - it appears the trouble came from the fact that the imported point cloud was located ten thousand units from the origin point.

It may be helpful to add a geometry to origin step after an import to prevent data being located at extreme distances from the origin.

I wonder if this could apply to most if not all import addons.

Details

Type
To Do

Event Timeline

Shane Ambler (sambler) set Type to To Do.
Shane Ambler (sambler) created this task.
Shane Ambler (sambler) raised the priority of this task from to Needs Triage by Developer.

The idea of To Do and Design tasks is that they are created by project members and developers who plan to work on these improvements or features, it's not for so much for people to suggest improvements, we don't really have the resources to keep track of and manage all that.

So, it's not clear to me if you plan to work on this, or if it's a suggestion that perhaps belongs elsewhere?
http://wiki.blender.org/index.php/Dev:Doc/Contact#Requesting_Features

While it's not really a bug on the blender importing as the real issue is at the initial data creation, I think it could be better if blender handled cases of bad data as shown in the stackoverflow example. I'm also expecting this could apply to more than just the ply import script. That's why I thought a todo would be better than bug report.

My initial thought is that adding a geometry to origin step after the import would be a simple fix for cases like this. I thought to open the discussion for anyone to offer better ideas or reasons that this may not be a good idea. Does it need to be an option that can be turned off or be off by default? I am concerned that some imports could be deliberately placed xx units from origin so they are in place with other objects after importing, maybe a limit of 1000 units from origin gets the transform applied. Also would this be limited to one or two import scripts or be an acceptable change for every import script.

It also may be a case of just documenting steps to take with bad imports, or documenting steps that an import script should consider taking or testing for during import.

Ok, so this is a usability issue and not a bug. A few suggestions like this wouldn't be a problem, but if we allow this in general we'd quickly end up discussing thousands of design issues or feature requests with no clear path to a developer working on them, and that's not an efficient way to get work done.

We still follow the same strict rules as on projects.blender.org basically, if it's a bug we try to fix it, if not all we can suggest is to use the mailing lists or contact the module team members.

I'll CC Campbell in case he has an opinion on this importer centering topic.

Brecht Van Lommel (brecht) closed this task as Archived.Dec 9 2013, 8:16 AM
Brecht Van Lommel (brecht) claimed this task.