Page MenuHome

OSL don't build with =ocio-1.3* and >=llvm-3.2 >=clang-3.2
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
gentoo ~amd64
Blender Version

Short description of error
please, forget me, i don't know the right place of my bug, and i try here
OSL don't compile with openimageio-1.3.5
http://bpaste.net/show/156851/
and with >=llvm-3.2 >=clang-3.2 don't build too
(With openimageio-1.1* and llvm-3.1* clang-3.1* builds fine)
Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps
Please fix osl code.
Thank you

Details

Type
Bug

Event Timeline

You seem to be building OSL from this repository, which is a personal fork:
https://github.com/DingTo/OpenShadingLanguage.git

The official repository is at:
https://github.com/imageworks/OpenShadingLanguage.git

Yes, i already build from this https://github.com/DingTo/OpenShadingLanguage.git repository.
What i need to do?

You need to build from the other repository :)

Brecht Van Lommel (brecht) closed this task as Archived.Dec 9 2013, 7:58 AM
Brecht Van Lommel (brecht) claimed this task.

Anyway, if you build from the Imageworks repository it should work. For Blender 2.70 we will use the 1.40 OSL release, which is in the RB-1.4 branch. Building latest Blender master with the OSL master branch should work as well, although once in a while it may be broken for a few days if the OSL guys do changes that we need to adapt to.

Thank you!!! Now i try to build from official repo and i get compiled osl-1.4 and, of course, blender
https://github.com/megabaks/stuff/blob/a9d013f190daf9793f61e3bdc4ec9b7286a52a1b/media-gfx/osl/osl-9999.ebuild