Page MenuHome

Delete Confirmation popup does not show when deleting an object in ObjectMode or deleting a marker in the Movie Clip Editor
Closed, InvalidPublic

Description

System Information
Windows 7 Professional; 4.00 GB of RAM; Operating System: 64-bit; Processors: 2 Intel(R) Core(TM)2 Duo CPUs P8700 @ 2.53GHz; Display Adapter: Mobile Intel(R) 4 Series Express Chipset Family

More information about my system are in these .txt files:

Blender Version
Broken: v2.69.7 Hash: 41e70cf

Worked: v2.69.0 r60995, and also v.2.69.8 Hash: 7647a2b


Short description of error
When I delete an object in ObjectMode or a marker in the Movie Clip Editor, the Delete confirmation popup doesn't appear. Instead, an i info bar appears at the top right of the info bar saying that it has been deleted. However, when I delete a marker in the timeline window, vertices, edges, faces etc. in EditMode on a mesh object, and a strip in the video sequence editor, the Delete confirmation popup does appear asking me if I want to confirm my deleting action.
Exact steps for others to reproduce the error

  1. In a default scene in Blender, select the cube in this case and then delete it with either the Delete key or the X key. The Delete confirmation popup should not appear if you are doing this in the Blender build v2.69.7 Hash: 41e70cf. Any other version should have this working.
  2. In the Movie Clip Editor, load in a video/movie clip into the Clip Editor, add in a marker with Ctrl+Left Click and track it perhaps, then delete it with either the Delete key or the X key. The Delete Confirmation popup should not appear which will ask you if you want to confirm the deletion of the marker if you are doing this in the Blender build v2.69.7 Hash: 41e70cf. Any other version should have this working.

Download the .blend files and the other files that I've provided for you to check the bug out for yourself:

Details

Type
Bug

Event Timeline

Thomas Dinges (dingto) closed this task as Invalid.Jan 13 2014, 1:15 AM
Thomas Dinges (dingto) claimed this task.

Why do you report a bug which is present in a 1 month old build, when you already have a recent build from January which works again?
This doesn't make any sense.

We removed the popup, but after use feedback decided to add back again.

Oh, sorry. I was actually creating a tutorial video on how to report bugs in Blender since both the Blender developer site and www.blender.org has been updated. I've decided to create an update on the video because of this. Anyway, sorry about that again. First off, I didn't know, and second I didn't know that this is not really a bug. And third, I couldn't think of anything else to sort of provide an example of a bug in Blender. This was my only option. Bugs for some reason just don't happen to me that quickly. Anyway, my video should be up on Vimeo soon. And I'm terribly sorry about this. I just didn't know. =)

No worries, it's not a big deal.

Just always check with the latest build, and if that works fine, then the problem has been fixed. :)