Page MenuHome

osl (git) don't compile with new llvm/clang v.3.4
Closed, InvalidPublic

Description

System Information
Operating system and graphics card
gentoo amd64

Short description of error
Hi. Sorry, if i post in wrong place
i can't compile osl with new clang-3.4 and llvm-3.4
osl from EGIT_BRANCH="RB-1.4"
http://bpaste.net/show/167458/
osl from EGIT_BRANCH="master"
http://bpaste.net/show/167461/
Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

Thomas Dinges (dingto) closed this task as Invalid.Jan 13 2014, 6:29 AM

You need the OSL master branch to compile with LLVM 3.4.
The error in the master log is from OIIO though, not llvm.

Anyway, not a Blender bug.

Oh, sorry, and thank you for reply!
Now i update openimageio to v.1.3.11 and osl was compiled!