Page MenuHome

critical 3d view transform and manipulator issues.
Closed, ResolvedPublic

Description

Operating System, Graphics card

cpu: intel core i3 2350 2.3 ghz
ram: 4 gb
gfx: intel hd graphics 3000
os: windows 7 home premium sp 1

Blender version with error, and version that worked

error found in: 5611fb6 win64
was working in: 4b206af win64

Short description of error

critical 3d view transform and manipulator issues

Steps for others to reproduce the error (preferably based on attached .blend file)

[apparently happens with all blend files including new startup.blend's]

erratic and apparently unusable transform of objects (including in mesh edit mode) after either selecting from menu or using g key while in front, side and top views, then either x or y axis key constraints.

might also be related to the corresponding axis not showing up on 3d manipulator.

Details

Type
Bug

Event Timeline

I was about to report this, too. It seems that the x / y manipulator are "missing". In 7 3 1 ortho mode.

@Leon Cheung (leon_cheung) I cant redo after testing each step you reference.

Rather then giving different issues that fail, could you give exact steps to redo the bug with just one?

You could also try test on a different system.

Can you double check this happens after loading factory settings?

@Campbell Barton (campbellbarton), I'm not the OP actually.

I'm using the latest offical build for win 64, (5611fb6) , it is problematic in this case (even after loading factory settings).

I just tried the latest git build for linux (a19f077), no problem then. I guess it has been fixed in (fab5438) ?

Thomas Dinges (dingto) lowered the priority of this task from Confirmed, High to Normal.

@ratty redemption (rattyredemption), please confirm whether it works or not now. And if it doesn't work as you expect please give exact steps to reproduce the issue.

@Sergey Sharybin (sergey) i just tested 5c74ac2win64 vc12 and both the 3d view transform and manipulator issues appear to be fixed.

however this version had the incorrect windows size issue reported here:

https://developer.blender.org/T37999

so it seems the win64 vc12 builds are still buggy in that regard.

Brecht Van Lommel (brecht) closed this task as Resolved.
Brecht Van Lommel (brecht) claimed this task.

Closing this report then as it appears to be fixed.