Page MenuHome

Lag on VSE
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
Asus g75vw
gentoo ~amd64 gtx660m (12gbRAM + 10gb swap)

Blender Version
Broken: all

Short description of error
Hi.
Thia is don't double of https://developer.blender.org/T38360 , this is same, but another issue
When i delete a strip or undo blender lag (freeze on about a minnite), blender dont crash just freeze and than worked again.
Please fix this issue.

Details

Type
Bug

Event Timeline

upd
freeze is becoming not after undo,
but after play video or change current cirsor position.

Does it happens even when you just started Blender?

If it happens after some time (and your mem is nearly completely used), this is just because of swapping on the HDD…

Yes
HDD and RAM don't in use.
It use one core cpu to 100%

UPDATE.
I try with diff opts and found that if i turn off OPENAL issue is GONE!
But i need sound too
Now i try with jack
If i found a way i will post it

All right,
the pronlem is in playing audio
(this is old problem and i work with different videos and sounds)
same with sdl jack and openal

May be i have wrong settings?
My settings is
stereo
48 kHz (because i have canon's mov with sound 48 kHz)
mix buf 512
32bit

May be issue is in my kde-4.12?

Hmmm… Maybe the buffer size is a bit small (I usually use 32k one, at 512 I get "segmented" sound), but I doubt this is the issue… A freeze of one minute is quite a big freeze!

Btw: I tried and confirm I cannot reproduce it here (Debian64, with OpenAL)…

Bigger buffer size (32768) don't fix my problem.

To reproduce - try to load group HD videos 1 hour long
and try random make play/delete/undo

Brecht Van Lommel (brecht) triaged this task as Normal priority.

This might have the same cause as T38360 and T23616 if it somehow has to open all the audio stream, but @Sergey Sharybin (sergey) and @Joerg Mueller (nexyon) would know more about this.

Thank you for reply!
No, memory (and swap) is no matter.
1 core of cpu is loading when lag is happening
Please fix it.

I upgrade my laptop to 20gb RAM and ssd disk.
The situation don't change...

I just randomly tried editing HD videos from my gopro, with lots of undo, cut and delete operations, no problems here. Do you have "Draw Waveform" on for the audio strips? What would help most to figure out the problem is, if you could compile blender yourself in debug mode and run it with a debugger, pausing it when it hangs and get a backtrace.

Please always do attach .blend file which demonstrates the issue wit hthe steps needed to reproduce the issue.

Hi, i can attach my scene file, but how about more than 50 GB of footage?
Do you mean that?

To check issue youself is simple:

  • open vse
  • load video peaces

(peaces like that (AVCHD h264 44M PCM https://drive.google.com/file/d/0B2gY2jqH8FS8OVhGeW85a2pqZjg/edit?usp=sharing )
more than on 30 min (1 hour would be better)
(now you may to see tis bug https://developer.blender.org/T38360)

  • turn on sdl or openal or jack sound
  • turn on AV-sync

http://i.imgur.com/uZApvVI.png
Now let's get edit.
Try randomly or accuracy to play/cut/delete/undo/rendo - you must to see that i want to describe.
Best regards,
Ilya

Here we go, your screenshot shows perfectly, why this could happen. As I asked before ("Do you have "Draw Waveform" on for the audio strips?") - try to turn of drawing the waveform of the audio strips and if that fixes it!

Hi, nexyon
I turn of all drawing the waveform - that don't fix it...

Have noticed this recently too. I can't really use undo now! I have to use an unstable build because the vse scripts don't work in the official, so I'm not sure if it happens in 2.69 official...

@David Salvo (slinkeepie), well it's interesting to know whether it works in official release or not.

Also, could see some addon being enabled there' Please give it a try with factory startup without extra addons enables. They could affect on performance..

And one more thing, does Cache Size have any affect on performance?

Sergey Sharybin (sergey) closed this task as Archived.May 19 2014, 5:46 PM
Sergey Sharybin (sergey) claimed this task.

No reply in quite a while. We can't fix bugs without being able to reproduce them anyway. So please attach as small as possible demonstration case so we can look into it.

For until then i'm archiving the report.