Page MenuHome

Tab coloring broken
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card
Arch Linux with AMD Radeon HD 6310 Graphics

Blender Version
Broken: 2.69.10
Worked: 2.69.8

Short description of error
The vertical tab strip in the tools panel on the left of the 3d view do not have proper coloring with some of the default themes. The coloring was correct with Blender 2.69.8.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

  1. Open a new file with Blender 2.69.10. My hash is c7ac0ed.
  2. Open the tools panel in the 3d view.
  3. Open the User Preferences window.
  4. Change the theme to "Blender 2.4x" (many others are broken as well; the default theme is not.)
  5. The tabs are very hard to read and seem to have incorrect coloring (e.g. almost no contrast).

Details

Type
Bug

Event Timeline

Forest Ka (forest-ka) set Type to Bug.
Forest Ka (forest-ka) created this task.
Forest Ka (forest-ka) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) triaged this task as Normal priority.

Campbell, think this one is for you?

I've discovered after fiddling with various settings that the default colors for the non-default themes (Ubuntu Ambiance, Hexagon etc.) have incorrect tab colors. After changing these, I was able to get a very readable tab bar.


However, the tab outlines seem to be two pixels wide instead of one pixel (probably antialiasing issue); should this be reported as a separate bug or is it a one-line fix?

Updated blender2.4x and hexagon, other themes are from addons_contrib and not officially maintained (each author needs to update)