Page MenuHome

Tabs: Switching between object and edit mode switches sometimes tabs.
Closed, InvalidPublic

Description

System Information
Windows 7 64bit
NVIDIA GeForce GTX 760

Blender Version
Broken: blender-2.69-a7b1349-win64

Short description of error
Tabs: Switching between object and edit mode switches sometimes tabs.

Exact steps for others to reproduce the error

I'm not sure if this is a bug.

Steps to reproduce:

  1. In object mode go to the tool shelf and click on the 'Create' tab.
  2. Go to edit mode and click on the 'Shading / UVs' tab
  3. Switch between object and edit mode and everything is fine
  4. Then click in the object mode on 'Create' again.
  5. Switch to edit mode and you see that the tab changed from 'Shading / UVs' to 'Create'
  6. It only works when there are tabs in object and edit mode that have the same name

There is also an issue with the panels: https://developer.blender.org/T38408

Details

Type
Bug

Event Timeline

Michael P. (forest-house) set Type to Bug.
Michael P. (forest-house) created this task.
Michael P. (forest-house) raised the priority of this task from to Needs Triage by Developer.

The Tabs in Edit Mode are different than the ones in Object Mode, imo it makes sense to keep them "separate", so no Bug i would say.
History indeed is missing.

I cannot replicate this here. Here it keeps the last tab selected per mode.

It keeps last selected per mode indeed, but changing active tab indeed affects all the modes.

Sergey Sharybin (sergey) triaged this task as Confirmed, Medium priority.Feb 3 2014, 12:59 PM
Brecht Van Lommel (brecht) closed this task as Invalid.

If there's a tab with the same name in multiple modes, then selecting that tab will also enable it in other modes. That is as it should be, definitely for tabs like Grease Pencil, and in my opinion also for tabs like Tools and Create.

@Brecht Van Lommel (brecht). I disagree, because the workflow in the modes is not exact the same. Example: Why should I use the grease pencil in object mode and than switch to edit mode and continue? Or add an object in object mode and go to edit mode and add another to the mesh? Sure this use case is plausible, but the user can do it anyway when this is fixed.

In my use case I add an object and than go to edit mode and work on the uvs. I can go back and add another object. And then work again on the uvs whitout wondering why the tab is set to create and why I have to switch it back to uvs.