Page MenuHome

Error writing frame
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card
gentoo ~amd64 Asus g75vw gtx660m
ffmpeg-2.1.2
Blender Version
Broken: in my git builds
Worked: in builder builds

Short description of error
Hi
When i select format to "Quicktime" and audio codec to "AAC" i get tis error after 19-22 frames
"Error writing frame"

Event Timeline

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.Feb 3 2014, 1:10 PM

This is rather lack of information needed for troubleshooting. Please include:

  • system-info.txt generated by Help->System Info
  • output of blender --debug-ffmpeg
  • .blend file which is set up in a way that gives the issue

Hi, thank you for reply, Sergey!
I open blender vse > load video (no matter what kind of) > QT+AAC > error after 19 frame (always)
http://i.imgur.com/q4pqoyk.png

system-info.txt
http://www.pasteall.org/49260
blender --debug-ffmpeg
http://bpaste.net/show/175050/

It doesn't seem to be FFmpeg-2.1.2 from the system info. Where did you get your FFmpeg from?

Tested with more recent FFmpeg from their official repo (hash 0e97ec54dea9330041f8a7ed30e4cd9a53c60e11, repo git://source.ffmpeg.org/ffmpeg.git) and couldn't have reproduced the issue.

Also, we're not officially supporting development versions of 3d part libs, so unless you've got the same issue with FFmpeg-2.1.3 i don't consider this is a bug. We couldn't guarantee there's no issues in 3d part libs source.

Hi
I understand. I use git version because it has vidstab support.
I alredy have the issue.

is git://source.ffmpeg.org/ffmpeg.git full analog repository of http://git.videolan.org/?p=ffmpeg.git;a=summary?

Does the issue happen with latest stable release of FFmpeg?

Then please provide:

  • config.log from FFmpeg 2.1.3 (official release, NOT git or so) compilation
  • Updated system-info.txt form blender
  • Output of blender --debug-ffmpeg
  • Sample .blend and image sequence/video demonstrating the issue (it is crucial to have since it might be some hidden option affecting on the result, also might depend on input video type)

i prepare all stuff here http://yadi.sk/d/SQi4P5lYHvAot

Thank you for the interest

Sergey Sharybin (sergey) raised the priority of this task from Needs Information from User to Confirmed, Medium.Feb 17 2014, 9:29 AM
Sergey Sharybin (sergey) claimed this task.

Managed to reproduce. You're using different AAC library than we're using for release (you're using libvo-aacenc which makes FFmpeg be GPL3+, we don't use it to keep it GPL2+).