Page MenuHome

Bevel profile at 1 makes errors
Closed, ArchivedPublic

Description

System Information
Windows 7 / Geforce GTS250

Blender Version
Broken: 7c9b106
Worked: None

Short description of error
Setting the bevel profile at 1 (with 2 segments) sometimes doesn't keep edges aligned in the expected way. This happens for edit mode tool and modifier.

Exact steps for others to reproduce the error
In the blend file turn the bevel modifier off and on to see the difference. Shouldn't a profile of 1 give the same contour as the original mesh?

Details

Type
Bug

Event Timeline

Bob Smith (uvwxyz) set Type to Bug.
Bob Smith (uvwxyz) created this task.
Bob Smith (uvwxyz) raised the priority of this task from to Needs Triage by Developer.
Howard Trickey (howardt) triaged this task as Normal priority.Feb 3 2014, 4:13 PM

Yes, I agree that bevel should do better in this case.
Unfortunately, the "profile=1.0" case is rather different from every other kind of profile, needs special code to handle properly. There's some special code already (e.g., for three faces all orthogonal to each other), but more special cases are needed, including your example.

I'm sorry that I write here. It is possible to add option that first and last faces in generated bevels were in the same plane as the original faces?

This will allow easy creation of beautiful bevels without subsurf by simply activating smooth shading
Currently, side faces look non-planar.

The first part of this report, using profile=1 on a triangular prism (bevel1.blend) is bug in the sense that no-one would agree that the current behavior is good; though it is not a regression since it has never worked since introducing the "profile" parameter. Unfortunately, fixing this requires a rethink and more special case code for the profile=1 case (similarly for the profile=0 case which is quite hard and therefore disabled right now). Too hard to fix in time for current 2.71 release.

The second part of this report, added by lopataasdf, is a feature request -- a reasonable one that I may get to next release cycle.

Howard Trickey (howardt) closed this task as Archived.Aug 26 2014, 1:54 PM

There is already a TODO in the wiki for redoing the way profile=1 is handled. Since this is not an easy task, and is not a regression, I am closing this report for now.