Page MenuHome

Addons use old links for bl_info['tracker_url']
Closed, ResolvedPublic

Description

Short description of error
Links for addons are outdated, they still point to projects.blender.org and svn.blender.org

Exact steps for others to reproduce the error
The tracker_url defined within every addon's bl_info still points to projects.blender.org.

It also appears that a good portion of the wiki_url pages for addons still have svn.blender.org links listed for download current version. (is that only contrib?)

developer.blender.org and git.blender.org have been running for over 2 months now, I think we should look at updating the addon links ready for the 2.70 release.

Details

Type
Bug

Event Timeline

Shane Ambler (sambler) set Type to Bug.
Shane Ambler (sambler) created this task.
Shane Ambler (sambler) raised the priority of this task from to Needs Triage by Developer.
codemanx renamed this task from Addons use old links. to Addons use old links for bl_info['tracker_url'].
codemanx claimed this task.
codemanx triaged this task as Confirmed, Medium priority.
codemanx closed this task as Resolved.Feb 4 2014, 3:11 AM

Cleaned up a lot of bl_info dicts and commited edits:

eab846e29355628b57f0a13303f1125325773b1b
049a5a86edcf78b070b73b141b657825145ae9a1

  • Removed unnecessary spaces (more PEP-8 compliant now)
  • No trailing \, because it's not needed here
  • Removed 'api' field
  • Removed ancient __bpydoc__
  • Nice-ified some version numbers, descriptions etc.
  • Removed white-space in empty lines in some files

Moan if I broke something!