Page MenuHome

Not possible to change keyed property in Video Sequencer
Closed, ArchivedPublic

Description

System Information
Windows 7 Ultimate 64 bit and Nvidia GeForce GTX 480

Blender Version
Broken: 2.69.0 r60995
Worked: (optional)

Short description of error
In Video Sequence Editor after adding keys to value in panels it is not possible to add another key.
Attempting to change the value of keyed property (Image Offset X or Y in the example) fails and the value is reset back to the keyed value.
A workaround is to key the same values on different frame and then move the corresponding F-Curve key but the resulting curve looks like staircase (see the blend file).

Exact steps for others to reproduce the error

  1. Add Scene as Strip in VSE
  2. In Properties panel enable Image Offset and key its X and Y values
  3. Go to another frame and try changing the keyed properties by typing or dialing (it should fail).
  4. Key the same values on another frame by pressing I key
  5. In Graph Editor move the key up or down - the curve looks like staircase.

Based on a (as simple as possible) attached .blend file with minimum amount of steps:
http://dox.bg/files/dw?a=f1f3760a7d

Details

Type
Bug

Event Timeline

Rumen Belev (syziph) set Type to Bug.
Rumen Belev (syziph) created this task.
Rumen Belev (syziph) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) closed this task as Archived.Feb 5 2014, 8:50 PM
Sergey Sharybin (sergey) claimed this task.

This is a known limitation of VSE -- it's not possible to edit animated values while having preview opened: http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Editors#Video_Sequencer

Unfortunately this issue is not simple to resolve and it's considered a TODO. Thanks for the report anyway!