Page MenuHome

Crash when selecting in wireframe/rendered viewport
Closed, ResolvedPublic

Description

System Information
Arch Linux 64
Intel i3-3217U
Intel HD 4000
xf86-video-intel-2.99.909-2
intel-dri-10.0.3-1
mesa-10.0.3-1 (OpenGL 3.0/3.3)

Blender Version
Broken: Official 2.69 + 2.69.10 6a2c467
Worked:

Short description of error
When selecting an object in wireframe viewport shading, Blender crashes instantly. This also happens when in rendered shading (BI/Cycles). Selection works fine in Solid, Textured and Bounding Box shading.

Exact steps for others to reproduce the error
In Blender default scene, deselect all, change viewport shading to wireframe, select cube -> crashes here

Details

Type
Bug

Event Timeline

Ejner Fergo (ejnersan) set Type to Bug.
Ejner Fergo (ejnersan) created this task.
Ejner Fergo (ejnersan) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) triaged this task as Normal priority.

Two questions:

  • Do you have VBOs enabled?
  • Does the crash happen with blender-softwaregl (you'll find it in official archives from blender.org and builder.blender.org)

Hi Sergey,

VBO was enabled! When turned off it doesn't crash in wireframe or rendered. Thanks! Of course would be nice if it didn't hard crash, but understand that the problem might be with Intel.

I couldn't find blender-softwaregl? Sorry.

Sergey Sharybin (sergey) closed this task as Resolved.Feb 6 2014, 5:35 PM
Sergey Sharybin (sergey) claimed this task.

It is a bug in Mesa which i've reported a while ago: https://bugs.freedesktop.org/show_bug.cgi?id=59455

Unfortunately, nothing we could do from blender side to workaround this driver bug. Thanks for the report!

P.S. blender-softwaregl is a script inside archive.