Page MenuHome

Ray Visibility problem mesh light blocking light from World env texture/sky model
Closed, ArchivedPublic

Description

System Information
OS X 10.8.5
GTX 570

Blender Version
Current Blender 2.6x

Short description of error
It seems while having shadow ray disabled a mesh light object still blocks some of the light from the world light.
It feels like the direct light is there but indirect light is blocked if I read this right.
The screenshot shows the problem. The images on the right show the difference between shadow and diffuse ray visibility flags.

I do not know if this is a bug or if this is a missing function because with a point light all works and no light is being blocked from the point light.

Exact steps for others to reproduce the error
Disable shadow visibility for a mesh but it still blocks some of the sky light.

Details

Type
Bug

Event Timeline

claas eicke (cekuhnendev) updated the task description. (Show Details)
claas eicke (cekuhnendev) raised the priority of this task from to Needs Triage by Developer.
claas eicke (cekuhnendev) set Type to Bug.
Brecht Van Lommel (brecht) closed this task as Archived.Feb 6 2014, 4:47 PM
Brecht Van Lommel (brecht) claimed this task.

Yes, it's a known strangeness in the way things work.

Diffuse rays are used to reach the world background right now because it's faster that way, they are being traced anyway for diffuse bounces so background lighting piggybacks on them. I'd like to make this work at some point but I'm not sure yet how to do it without impacting performance.

Thanks for the confirmation.

A doable work around seems to be to use the light path for the mix factor.