Page MenuHome

Images with alpha values does not mix correctly in sequencer
Closed, ArchivedPublic

Description

System Information
Mac OS X 10.9

Blender Version
Broken: 2.69.0

Short description of error
When mixing two images in sequencer, the alpha values does not mix the same way it mixes in Compositor. To me it seems to be a Sequencer issue.

Exact steps for others to reproduce the error
Export in compositor some image with details in alpha. Import it on Sequencer. It will not show/render the same way it would show/render in Compositor.

Details

Type
Bug

Event Timeline

Jonata Bolzan (jonata) raised the priority of this task from to Needs Triage by Developer.
Jonata Bolzan (jonata) updated the task description. (Show Details)
Jonata Bolzan (jonata) set Type to Bug.


Here is the image on sequencer.


And here is the same image on compositor.

In both cases, I mix the same image with plain white background.

Here are some more examples. As you can see in the details, it seems that in sequencer some black color, or dark, is added to the alpha values.



Here is the compositor. As you can see, the edges are rendered correctly.



Here is in the sequencer, the same image and the same effect (Alpha over).


Here is the blend file. Both sequencer and compositor examples.

Okay, I've downloaded the blend file, but could you also upload some of the test images that you used to test the bug out so that I could look at it myself?

The following is the file and the image I generated with some alpha values.


Below is a test I made rendering on Sequencer and on Compositor, using the same effect "Alpha Over".

- On Sequencer

- On Compositor

Now even though I'm running on Windows 7 Professional x64-bit, this has happened to me too.

Here's what it looks like for me in both the compositor and the sequencer:

Here's a scene of what this looks like for me in the compositor:

...and here's the result:

Here's a scene of what this looks like for me in the sequencer:

...and here's the result:

I've provided some files for you look at if you want to which include the image that you've uploaded:

Now, even though it works for me too, it doesn't seem to be a bug at all. It's probably an issue with the video sequence editor. So, while working in Blender, when rendering an alpha over image, you'll have to compare and contrast of what image looks best whether it's in the compositor or the sequencer. Maybe...... just maybe....... this issue will probably get fixed in a later version or svn build of Blender in the future. We'll just have to see.

Thanks for reproducing the issue.

The last thing I want to see is that kind of war "it is not a bug, it is a feature". As you mentioned, it is an issue with the sequencer, so it is a bug, and I think it should be treated properly. This is an option/effect without the expected behavior.

Sergey Sharybin (sergey) closed this task as Archived.Mar 20 2014, 9:08 AM

It's not really a bug here. Compositor works with premtiplied linear colors, sequencer works in straight display space colors.

Now, what is a bit weird in compo is that alpha over there actually expects straight alpha, and since you're using keying node and not using Convert Premul button you've got proper result in the compositor. But i guess you're using the same image in sequencer which is stored with straight alpha and for sure sequencer wouldn't give the same result as compositor does.

This might sound a bit complicated and making it more clear what's going on is on our TODO list. Thanks for the report, but currently it looks everything works as it's designed to..