Cycles - Image is always premultiplied, even when alpha output is not being used
Closed, InvalidPublic

Description

System Information
Windows 7 x64, gtx 580,

Blender Version
Broken: ac27a1a

Short description of error
From the wiki it states "RGB color from image. If the image has alpha, the color is premultiplied with alpha if the Alpha output is used, and unpremultiplied or straight if the Alpha output is not used."
However, in use, the color is ALWAYS premultiplied with the alpha.. This makes it hard to load in other information into the alpha slot (such as masks for the image texture)

Exact steps for others to reproduce the error

  1. Open attached blend file
  2. press shift z on the viewport
  3. notice how there is black in the gradient, whereas it should be nice and smooth

Details

Type
Bug
Brecht Van Lommel (brecht) closed this task as Invalid.EditedFeb 11 2014, 3:44 PM

That's how it is intended to behave currently, if you have images with zero alpha in areas it will always be black. I can see that it is sometimes useful to separate them, but it's not supported currently. All I can suggest now is to use the alpha channel for alpha only.

There is a simple workaround for this, you can uncheck use alpha in the image properties. If you need alpha mask create another image with the same source and use alpha checked this time.