Page MenuHome

H.264 file format with PNG encoding give
Closed, ResolvedPublic

Description

System Information
OS: Ubuntu 13.10
Linux kernel: 3.11.0-15-generic

Graphics:
VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)

Blender Version
Broken: Blender 2.69 77a15ab

Short description of error

Using H.264 and PNG codec, causes a segmentation fault.

Exact steps for others to reproduce the error

  1. Open a new .blend file
  2. Under Render tab, and under the Output header, set file format to H.264
  3. Under the Encoding header, set Codec to PNG.
  4. Press Animation in Render tab. It will either give "Error: Specified pix_fmt is not supported" or have a segmentation fault. If you get the error, hit Animation again. It will eventually have the segmentation fault (and crash).

(Blender 2.69 r60991 does not seg fault, only gives that error message)

Here is a .blend with the first 3 steps completed:


Upon crashing it wrote out this .crash.txt file:

Details

Type
Bug

Event Timeline

Garrett (Garrett) set Type to Bug.
Garrett (Garrett) created this task.
Garrett (Garrett) raised the priority of this task from to Needs Triage by Developer.

It seems to culprit is RGBA. If set this to RGB i have no issues.
On osx the error with RGBA is:
Error: Error writing frame

Sergey Sharybin (sergey) closed this task as Resolved.Feb 18 2014, 7:56 AM

Looks like it's fixed in rB2175302. At least buildbot builds doesn't crash for me anymore.

Thanks for the report, closing it now!

Great, thanks! The problem is gone for me in the latest build too.