Page MenuHome

Clipboard erased when quitting Blender
Closed, ResolvedPublic

Description

System Information
OS: Ubuntu 13.10
Linux kernel: 3.11.0-15-generic

Graphics:
VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)

Blender Version
Broken: blender-2.69-cc7cfd6-linux-glibc211-x86_64

Short description of error

When you quit Blender, anything you had copied inside Blender to clipboard is erased.

Exact steps for others to reproduce the error

  1. Open Blender
  2. Switch to Text Editor and hit "New"
  3. Type anything, highlight it and hit CTL+C
  4. Quit Blender
  5. Open any text editor, press CTL+V and the text will not be pasted

Here's a .blend file with (1) and (2) completed:

Details

Type
Bug

Event Timeline

Garrett (Garrett) added a project: BF Blender.
Garrett (Garrett) set Type to Bug.
Garrett (Garrett) created this task.
Garrett (Garrett) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) closed this task as Resolved.Feb 17 2014, 11:12 AM
Sergey Sharybin (sergey) claimed this task.

This is out of our control actually. We're only telling X to put something to the clipboard and unless some clipboard manager is hooked into your system you'll loose content of the clipboard on application exit.

It's nothing we can change here from our side, it's just how X works. Thanks for the report anyway.

P.S. Clipboard manager here on KDE works just fine allowing to paste stuff which was copied from closed blender.

Thanks for the explanation! I've posted a Q&A on Blender Stack Exchange to elaborate.

Apparently this could be fixed by complying to this freedesktop convention, the responsibilities of clipboard owner: http://www.freedesktop.org/wiki/ClipboardManager
This ubuntu bug confirms that some programs do have this fixed, but also other major ones like open office don't: https://bugs.launchpad.net/ubuntu/+bug/11334
Probably not a priority to get it working, since most linux distros come with a clipboard manager by default.