Page MenuHome

Transforming keyframes in dope sheet causes weird result in graph editor
Closed, ArchivedPublic

Description

Version: 2.69 official (win 64)

How to reproduce: In the dope sheet of the provided .blend file, select some keyframes and grab/duplicate them. Notice that as you slide those keyframes in the dope sheet, weird, impossible f-curves show up in the graph editor.

Once you left click to drop the keyframes, the curve goes back to normal. This bug is a very minor one, as it has no real effect on the animation. It only affects the appearance of the f-curves during transformation.

Details

Type
Bug

Event Timeline

Sam Brubaker (rocketman) set Type to Bug.
Sam Brubaker (rocketman) created this task.
Sam Brubaker (rocketman) raised the priority of this task from to Needs Triage by Developer.
Joshua Leung (aligorith) closed this task as Archived.Feb 18 2014, 4:24 AM
Joshua Leung (aligorith) claimed this task.

Without (needing to) checking the file, this sounds like it's simply a case of the keyframes not being sorted until after the transform is completed.

The F-Curve drawing is highly dependent on the keyframes in the curve being in the correct order. For transforms initiated in the Graph Editor, we had to add an extra sorting step after each transform step/update. However, currently, we don't do the same for the Dopesheet as 1) most of the time no-one will notice that it's going weird (since the curves aren't shown there), and 2) introducing this sorting step adds a significant amount of complexity to the code (since we need to keep track of what moved and what hasn't, fiddle all that around, hook it up, etc. etc.). Admittedly, this overhead is one of the reasons updates/tweaks/changes to the Graph Editor transform code are few and far between these days.

(Perhaps the only scenario when people are likely to notice that the curves are going wacko are if they use the default Animation workspace, which shows both editors one on top of the other. Then again, I don't believe that this is the best way to use these editors, and it's definitely not how they were designed...)

Now, unless we get a stream of reports that complain about the stuff jiggling around erratically in the viewport or elsewhere (AND causing significant issues due to that) while transforming keyframes in the dopesheet (from having the time cursor placed in the wrong place), it's probably not worth the trouble to fix this.

Thanks, @Joshua Leung (aligorith)! I believe you if you say that this issue is more trouble than it is worth to fix.

One small point, though: More often than not, I *do* have both the Graph Editor and the Dope Sheet side-by-side together. I think a lot of animators do. I'm not trying to change your mind about this bug; I just wanted to let you know how I work.