Page MenuHome

preview render bug (Cycles)
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card Windows 7 CPU

Blender Version
Broken: (example: 2.7 10f4c62, see splash screen)
Worked: (optional)

Short description of error
If you have a large scene, then usualy one would create small props for the scene on a different object layer; and when ready place them in the main layer. While working on a huge scene, and making a prop in another layer. I noted that if one sets the preview screen to cycles render mode.
Then despite my prop object is small, and its the only object in my viewport at layer; despite the whole scene; everything is calculated (BHV / Duplicates etc)..
It should only render those object that are on the screen in this layer, not other layers..

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps
My blend file is a bit large, but just take a huge one yourself.
Then create a simple object (monkey or so) on another layer and render that object layer.

Details

Type
Bug

Event Timeline

Peter Boos (PGTART) set Type to Bug.
Peter Boos (PGTART) created this task.
Peter Boos (PGTART) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) renamed this task from preview render bug to preview render bug (Cycles).
Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.Feb 22 2014, 4:49 PM

I can't confirm this with some complex files here, we need a .blend file to demonstrate the problem. Perhaps you can try replacing that complex scenes with just one object with a subdivision surface modifier with many subdivision and see if it still happens, and if not figure out which object(s) in your scene are causing this problem.

There is some overhead when you have objects on hidden layers, but it shouldn't be that much, and certainly not affect the BVH building. Maybe it is related some render layers setup, but I couldn't find anything in tests here.

Today i tried to reproduce it again,
It was really obvious the last time, i was working on something small in another layer.
It took a long time to get a cycle preview of it.
For my main scene the bhv build was around 1.5 minute
I had the wait the same time for my small object.
It happened the whole evening while i worked on it, i wasn't sure if it was related to the latest build, but i didn't retried it with an older build.
Today worked on it again.. and so far it hasn't happen.
I'm not sure what is so much different from that day and today.

This leaves me a bit clue less, i was thinking that it was caused by the size of my rendering on the main layer which has 400.000 faces textures and complex cycles materials with a total blend file size around 35Mb (my system has 24GB ram)

I will check if there is a memory leak (using sysinternal tools).

I will share the file too if it happens again

Thomas Dinges (dingto) closed this task as Resolved.

Can re-open this, when we have a .blend we can use to redo the problem.