Page MenuHome

Sculpt Mode Ctrl + Right Click Shortcut absent
Closed, ResolvedPublic

Description

System Information
Win7 x64, GTX 590

Blender Version
Broken: (Blender 2.69.11 Hash e7f3424)
Worked: (Official 2.69)

Short description of error
The shortcut CTR+Right Click is absent on newer builds (This is extremely useful when you want to switch from one object to another while scultpting, some kind of Zbrush "sub tools" on Blender.

Exact steps for others to reproduce the error

0.-With the default cube:

1.- Dublicate the defaut cube and put the copy above the first (original cube)
2.- Switch to sculpt mode on the Cube.001 (the copy)
3.- Now if you hold CTR + Right click and click the original cube you notice that you've switched from cube.001 to the original cube, now with this cube selected (The original), switch again to sculpt mode.
4.- Notice if you want to switch from one cube to another just use the CTR+Right click.

5.- What are the advantages of this? Imagine if you had a character and then you want to quickly sculpt a helmet or a hat, with this technique is very easy and quick to do it without having to switch manually from one object to another.

6.- Completely absent on newer builds....

Details

Type
Bug

Event Timeline

Angel Pat (valcar3d) raised the priority of this task from to Needs Triage by Developer.
Angel Pat (valcar3d) updated the task description. (Show Details)
Angel Pat (valcar3d) set Type to Bug.
Brecht Van Lommel (brecht) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Feb 24 2014, 8:43 PM

It seems this got lost in {1fb9bb815a5df8ba3b4b2ebdaa4cad192fecd145}.

This was never intended to work.

Ctrl+RMB

  • Edit-mode allows selecting objects for vertex parenting.
  • Object-mode selects objects from their center points only.

Blender 2.4x (where this convention was established) didn't allow Ctrl+RMB select in sculpt mode either, from what I can see Ctrl+RMB worked for some time in 2.6x more or less by accident.

Not that the behavior is bad to have, just I wouldn't call it a bug.

Vertex, Weight & Texture paint all allow selection, but sculpt mode explicitly exits,

view3d_select_exec checks for sculpt mode and exits,

	 else if (obact && obact->mode & OB_MODE_SCULPT)
	 	return OPERATOR_CANCELLED;

I can't see why all the other paint modes would work but not sculpt.

The commit that changed this was rB0e37b49a2c2f3693db834295262b2f041799c542

Would this be because paint conflicts with LMB select?

As reported in T38837: Can not select any bone in Weight Paint mode with Face selection masking it seems this was also useful in weight paint mode, so even if it's not strictly a bug I think it's still important to keep this working.

As for why I added that OPERATOR_CANCELLED for sculpt, I don't remember well. I think back then right click was color sampling in paint modes, and you couldn't select other objects anyway, so in some way this made things more consistent because sculpt was the only mode where you could switch objects with just right click. Border and circle select are already be used for masking in sculpt mode outside of this selection operator so it doesn't make sense to handle there.

I would make ctrl + click outside of object mode always do object selection, without the center point thing like this:

@Brecht Van Lommel (brecht), checked the patch and it breaks ctrl+rmb select behavior in object mode (where only the object centers should be considered), will check on having it work.

Am not really happy how this process is working where some keys are accessible by accident then we have to support some oddly mixed configurations. Since 2.70 allows to break/change some behavior we could accept the change.

IMHO the report about sculpt is related to there being no key bindings to exit sculpt mode, so users got used to exiting by selecting another object.

I checked the "Sculpt" keymap and RIGHTMOUSE isnt used anywhere, so we could allow object selection in that case. But this still leaves Weightpaint+facemask+posemode...

It's late in the release cycle to be making changes so.. I'll check on how this could improved.

Campbell Barton (campbellbarton) closed this task as Resolved.EditedFeb 26 2014, 7:10 AM

Fixed rB4a61df9c95d48c0854d49869eac2d3dc0453b7f4 rB1dd7e759a0df10b05f23527eb6ba0c8e7377fbea

Now sculpt mode can select without ctrl (as with other paint modes), and there is an exception for select+paint modes so they are treated like editmode.