Page MenuHome

Render bug as result of curve modifier animation
Closed, ArchivedPublic

Description

Windows 7 Professional w Service Pack 1
ASUS nVidia GeForce GTX 760 2GB GDDR5 DirectCU Mini

Broken: All versions of Blender tested from 2.69 and later

:::::::::::

There is a possible bug as a result of overlapping influences of movement and scale combined with the curve deform modifier.

Usually this simply causes render problems. It also caused a crash once, but I cannot reproduce that.

Just to explain what I have done:

I was attempting to make a moving deformation of a surface by using a curve deform modifier.

Having made a curve, I then pulled down a few of its vertices away from 0 on the Z axis in order to form the required deformation. I then animated the entire curve back and forth on the Y axis to move the point at which my deformation would affect the surface. This worked as expected.

Then thinking to take the animation a step further, I used the “Animall” plugin to animate the points of the curve object to make the deformation grow and shrink in size... at times down to 0 on the Z axis. Again, this worked as expected.

Finally, I decided that it might be interesting to scale the curve, itself, on the Z axis in order to introduce yet more irregularity of motion into the animation. This is where things began to go wrong.

If I scaled my curve object down to something like 0.001 on the Z axis there where no problems. If, however, I scale it down to true zero (0) on the Z axis the render goes completely wrong.

The problem can be seen at frames 60 and 150 as well as one frame to either side of those.

To my way of thinking the scale operation(s) I animated into the curve should only affect the vertices of the curve object and not the surface that the curve object is affecting by way of the deform modifier.

Unfortunately, this appears not to be the case and it looks as if the scale of the curve object is somehow affecting the scale of the surface object... thus causing the render problem.

Please examine. Thank you.

Details

Type
Bug

Event Timeline

Ignatz (ignatz) added a project: BF Blender.
Ignatz (ignatz) set Type to Bug.
Ignatz (ignatz) added a subscriber: Ignatz (ignatz).
Ignatz (ignatz) created this task.
Ignatz (ignatz) raised the priority of this task from to Needs Triage by Developer.

@Sergey Sharybin (sergey), I think this is exactly the same issue as T38870, i.e. invert matrix with one axis set to zero (null scale along Z here too)?

I’ll let you decide whether those two reports can be merged, though…

Bastien Montagne (mont29) triaged this task as Normal priority.Mar 1 2014, 5:52 PM
Sergey Sharybin (sergey) closed this task as Archived.May 19 2014, 4:51 PM

This involves matrix inverse and since curve is zero-scaled it's matrix is degenerated. Could be hacked, but wouldn't consider a bug. Moved to TODO: http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Tools#Curves

Thanks for the report anyway!