Page MenuHome

Edit mode: drawing bug when enabling i18n
Closed, ArchivedPublic

Description

System Information
Win XP SP3

Blender Version
2.69 60995

Short description of error

I'm experiencing some strange behavior of blender. if I load factory settings no problem. If I change settings like in the attached video file I see some kind of double nested cube (or other shape) into the mesh when I click TAB to enter in EDIT mode and rotate the view.
See the video to see what I see. Hope the mp4 format is good for everyone.

Details

Type
Bug

Event Timeline

william willybid (willybid) updated the task description. (Show Details)
william willybid (willybid) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) renamed this task from Edit mode: unwanted cube nested inside the correct one. to Edit mode: drawing bug when enabling i18n.Mar 3 2014, 8:50 AM
Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

This looks like a nasty OpenGL drawing bug…

We really need your exact GPU and driver versions (attaching the content of your System Info [Help menu, then text found in Text window] would be good too).

Quote:
"This looks like a nasty OpenGL drawing bug…"

Why it happens AFTER editing user preferences and not with blender defaults?

Anyway I hope this helps

Blender 2.69 (sub 0) System Information

Blender:

version 2.69 (sub 0), revision b'60995'. b'Release'
build date: b'2013-10-30', b'16:37:17'
platform: b'Windows:64bit'
binary path: 'C:\\Programmi\\Blender Foundation\\Blender\\blender.exe'
build cflags: b'-DWITH_FREESTYLE /nologo /J /W1 /Gd /wd4018 /wd4244 /wd4305 /wd4800 /wd4065 /wd4267 /we4013 /openmp -O2 /Ob2 -DNDEBUG -DWIN32 -D_CONSOLE -D_LIB -D_CRT_SECURE_NO_DEPRECATE -DOPJ_STATIC -DWITH_MOD_FLUID -DWITH_MOD_OCEANSIM -DLITTLE_ENDIAN -DWITH_AUDASPACE -DWITH_AVI -DWITH_BOOL_COMPAT'
build cxxflags: b'/nologo /J /W1 /Gd /wd4018 /wd4244 /wd4305 /wd4800 /wd4065 /wd4267 /we4013 /openmp /EHsc -O2 /Ob2 -DNDEBUG -DWIN32 -D_CONSOLE -D_LIB -D_CRT_SECURE_NO_DEPRECATE -DOPJ_STATIC -DWITH_MOD_FLUID -DWITH_MOD_OCEANSIM -DLITTLE_ENDIAN -DWITH_AUDASPACE -DWITH_AVI -DWITH_BOOL_COMPAT'
build linkflags: b'/SUBSYSTEM:CONSOLE /MACHINE:IX86 /STACK:2097152 /INCREMENTAL:NO /LARGEADDRESSAWARE /NODEFAULTLIB:msvcrt.lib /NODEFAULTLIB:msvcmrt.lib /NODEFAULTLIB:msvcurt.lib /NODEFAULTLIB:msvcrtd.lib'
build system: b'SCons'

Python:

version: 3.3.0 (default, Nov 26 2012, 17:23:29) [MSC v.1500 32 bit (Intel)]
paths:
'C:\\Documents and Settings\\MontaggioVideo\\Dati applicazioni\\Blender Foundation\\Blender\\2.69\\scripts\\addons'
'C:\\Programmi\\Blender Foundation\\Blender\\2.69\\scripts\\addons'
'C:\\Programmi\\Blender Foundation\\Blender\\2.69\\scripts\\startup'
'C:\\Programmi\\Blender Foundation\\Blender\\2.69\\scripts\\modules'
'C:\\Programmi\\Blender Foundation\\Blender\\python33.zip'
'C:\\Programmi\\Blender Foundation\\Blender\\2.69\\python\\DLLs'
'C:\\Programmi\\Blender Foundation\\Blender\\2.69\\python\\lib'
'C:\\Programmi\\Blender Foundation\\Blender'
'C:\\Programmi\\Blender Foundation\\Blender\\2.69\\python'
'C:\\Programmi\\Blender Foundation\\Blender\\2.69\\python\\lib\\site-packages'
'C:\\Programmi\\Blender Foundation\\Blender\\2.69\\scripts\\addons\\modules'
'C:\\Documents and Settings\\MontaggioVideo\\Dati applicazioni\\Blender Foundation\\Blender\\2.69\\scripts\\addons\\modules'

Directories:

scripts: ['C:\\Programmi\\Blender Foundation\\Blender\\2.69\\scripts', 'C:\\Documents and Settings\\MontaggioVideo\\Dati applicazioni\\Blender Foundation\\Blender\\2.69\\scripts']
user scripts: 'C:\\Documents and Settings\\MontaggioVideo\\Dati applicazioni\\Blender Foundation\\Blender\\2.69\\scripts'
pref scripts: None
datafiles: 'C:\\Documents and Settings\\MontaggioVideo\\Dati applicazioni\\Blender Foundation\\Blender\\2.69\\datafiles\\'
config: 'C:\\Documents and Settings\\MontaggioVideo\\Dati applicazioni\\Blender Foundation\\Blender\\2.69\\config\\'
scripts : 'C:\\Documents and Settings\\MontaggioVideo\\Dati applicazioni\\Blender Foundation\\Blender\\2.69\\scripts\\'
autosave: 'C:\\Documents and Settings\\MontaggioVideo\\Dati applicazioni\\Blender Foundation\\Blender\\2.69\\autosave\\'
tempdir: 'C:\\DOCUME~1\\MONTAG~1\\IMPOST~1\\Temp\\'

FFmpeg:

'avcodec':' ''53, 60, 100'
'avdevice':' ''53, 4, 100'
'avformat':' ''53, 31, 100'
'avutil':' ''51, 34, 101'
'swscale':' '' 2, 1, 100'

OpenGL

renderer: 'ATI Radeon HD 5400 Series'
vendor: 'ATI Technologies Inc.'
version: '4.2.11318 Compatibility Profile Context'
extensions:

		'GL_AMDX_debug_output GL_AMDX_vertex_shader_tessellator'
		'GL_AMD_conservative_depth GL_AMD_debug_output'
		'GL_AMD_depth_clamp_separate GL_AMD_draw_buffers_blend'
		'GL_AMD_multi_draw_indirect GL_AMD_name_gen_delete'
		'GL_AMD_performance_monitor GL_AMD_pinned_memory'
		'GL_AMD_sample_positions GL_AMD_seamless_cubemap_per_texture'
		'GL_AMD_shader_stencil_export GL_AMD_shader_trace'
		'GL_AMD_texture_cube_map_array GL_AMD_texture_texture4'
		'GL_AMD_transform_feedback3_lines_triangles'
		'GL_AMD_vertex_shader_tessellator GL_ARB_ES2_compatibility'
		'GL_ARB_base_instance GL_ARB_blend_func_extended'
		'GL_ARB_color_buffer_float GL_ARB_compressed_texture_pixel_storage'
		'GL_ARB_conservative_depth GL_ARB_copy_buffer GL_ARB_depth_buffer_float'
		'GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers'
		'GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex'
		'GL_ARB_draw_indirect GL_ARB_draw_instanced'
		'GL_ARB_explicit_attrib_location GL_ARB_fragment_coord_conventions'
		'GL_ARB_fragment_program GL_ARB_fragment_program_shadow'
		'GL_ARB_fragment_shader GL_ARB_framebuffer_object'
		'GL_ARB_framebuffer_sRGB GL_ARB_geometry_shader4'
		'GL_ARB_get_program_binary GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64'
		'GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging'
		'GL_ARB_instanced_arrays GL_ARB_internalformat_query'
		'GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multisample'
		'GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2'
		'GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite'
		'GL_ARB_provoking_vertex GL_ARB_sample_shading GL_ARB_sampler_objects'
		'GL_ARB_seamless_cube_map GL_ARB_separate_shader_objects'
		'GL_ARB_shader_atomic_counters GL_ARB_shader_bit_encoding'
		'GL_ARB_shader_image_load_store GL_ARB_shader_objects'
		'GL_ARB_shader_precision GL_ARB_shader_stencil_export'
		'GL_ARB_shader_subroutine GL_ARB_shader_texture_lod'
		'GL_ARB_shading_language_100 GL_ARB_shading_language_420pack'
		'GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_shadow_ambient'
		'GL_ARB_sync GL_ARB_tessellation_shader GL_ARB_texture_border_clamp'
		'GL_ARB_texture_buffer_object GL_ARB_texture_buffer_object_rgb32'
		'GL_ARB_texture_compression GL_ARB_texture_compression_bptc'
		'GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map'
		'GL_ARB_texture_cube_map_array GL_ARB_texture_env_add'
		'GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar'
		'GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_gather'
		'GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample'
		'GL_ARB_texture_non_power_of_two GL_ARB_texture_query_lod'
		'GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui'
		'GL_ARB_texture_snorm GL_ARB_texture_storage GL_ARB_timer_query'
		'GL_ARB_transform_feedback2 GL_ARB_transform_feedback3'
		'GL_ARB_transform_feedback_instanced GL_ARB_transpose_matrix'
		'GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra'
		'GL_ARB_vertex_array_object GL_ARB_vertex_attrib_64bit'
		'GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader'
		'GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array'
		'GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_envmap_bumpmap'
		'GL_ATI_fragment_shader GL_ATI_meminfo GL_ATI_separate_stencil'
		'GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3'
		'GL_ATI_texture_float GL_ATI_texture_mirror_once GL_EXT_abgr'
		'GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color'
		'GL_EXT_blend_equation_separate GL_EXT_blend_func_separate'
		'GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array'
		'GL_EXT_copy_buffer GL_EXT_copy_texture GL_EXT_direct_state_access'
		'GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements'
		'GL_EXT_fog_coord GL_EXT_framebuffer_blit'
		'GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object'
		'GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4'
		'GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_histogram'
		'GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil'
		'GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object'
		'GL_EXT_point_parameters GL_EXT_provoking_vertex GL_EXT_rescale_normal'
		'GL_EXT_secondary_color GL_EXT_separate_specular_color'
		'GL_EXT_shader_image_load_store GL_EXT_shadow_funcs GL_EXT_stencil_wrap'
		'GL_EXT_subtexture GL_EXT_texgen_reflection GL_EXT_texture3D'
		'GL_EXT_texture_array GL_EXT_texture_buffer_object'
		'GL_EXT_texture_compression_bptc GL_EXT_texture_compression_latc'
		'GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc'
		'GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp'
		'GL_EXT_texture_env_add GL_EXT_texture_env_combine'
		'GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic'
		'GL_EXT_texture_integer GL_EXT_texture_lod GL_EXT_texture_lod_bias'
		'GL_EXT_texture_mirror_clamp GL_EXT_texture_object'
		'GL_EXT_texture_rectangle GL_EXT_texture_sRGB'
		'GL_EXT_texture_shared_exponent GL_EXT_texture_snorm'
		'GL_EXT_texture_storage GL_EXT_texture_swizzle GL_EXT_timer_query'
		'GL_EXT_transform_feedback GL_EXT_vertex_array GL_EXT_vertex_array_bgra'
		'GL_EXT_vertex_attrib_64bit GL_IBM_texture_mirrored_repeat'
		'GL_KTX_buffer_region GL_NV_blend_square GL_NV_conditional_render'
		'GL_NV_copy_depth_to_color GL_NV_explicit_multisample'
		'GL_NV_float_buffer GL_NV_half_float GL_NV_primitive_restart'
		'GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGIS_generate_mipmap'
		'GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod'
		'GL_SUN_multi_draw_arrays GL_WIN_swap_hint WGL_EXT_swap_control'

Thanks all for help and disponibility.

You might consider updating your drivers! 2011/11, more than two years old…

Also, if updating does not fix the issue, you could try with different settings in user preferences, System tab (with/without VBO, disabling anisotropic filtering and/or multisample, etc.).

You may also try running blender-softwaregl script distributed with Blender (it bypasses GPU acceleration, gives low performances but if it works, you know issue is with your graphic driver).

Quote:

"This looks like a nasty OpenGL drawing bug…"

Why it happens AFTER editing user preferences and not with blender defaults?

Might be a graphical memory issue - chars are cached in textures in Blender, so enabling translation you enable much more characters, hence (graphical) memory used by fonts may grow up, and GC get out of mem for remaining scene. Only a whild guess, but…

Thanks for response. I followed your suggestion and the previous problem seems to be solved... but now I'm getting a new problem never happened before. It is showed into the following image:

As you can see into the red rectangle that I have drawn to highlight the problem I'm getting now, there are some white rectangular "artifacts" that appear when I move the mouse. Also the orange line of the left edge appears broken after I passed on it with the mouse cursor.

Any way I usually use Blender Render not Cycles

Bastien Montagne (mont29) claimed this task.

Well, definitively looks like a GPU driver bug/limitation, not much things we can do I’m afraid…