Page MenuHome

Bevel in edit mode.
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card
Macintosh osX lion 10.7.5, no graphics card
Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)
2.7 (Date 2014-02-20 05:32) 4789793
Short description of error
Bevel on starter cube in edit mode causes crash. A single cut is possible but when or after some segments have been added using F6 a crash occurs. The tool does not reset either, meaning that when applying a second bevel it generates more than one indent at once.
Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps
Create a base cube, go into edit mode on it. apply a bevel to an edge, left click. press F6 slide to max, add four segments, make them outward fully. click the vertex tab. Repeat this process after or prior to cleaning up the ngons. The crash for my system occurs on trying to increase or decrease amount. thanks

Event Timeline

Predrag Lazic (particl3s) raised the priority of this task from to 90.
Predrag Lazic (particl3s) updated the task description. (Show Details)
Predrag Lazic (particl3s) edited a custom field.

Can’t reproduce that here (Debian64, latest master).

Can't reproduce on OSX.
So to clarify, you are saying it is broken on 2.69.7, but works on 2.7 4789793?

No, bevel works fine in 2.69.7.

It busts on 4789793, mostly when using F6 menu

Yes, confirm that is breaking in 2.7 release candidate.
But that bug was fixed in T38742
If you download the latest build from BuildBot you will see it is fixed.

Bastien Montagne (mont29) changed the task status from Unknown Status to Resolved.Mar 5 2014, 10:22 AM
Bastien Montagne (mont29) claimed this task.

Closing, in this case! :)