Page MenuHome

Node dirver bug in Material and Texture
Closed, ResolvedPublic

Description

System Information
win7 64 bit sp1
amd card hd7700

Blender Version
Broken: 2.69.0 r60995 *and* 2.70 hash:571f184
Worked: not sure

Short description of error
Node dirver bug in Material[BI and Cycles] and Texture. But working with Compositing node.
The screenshot would be helpful.

Exact steps for others to reproduce the error
Set the same value driver.
Node Compositing [right]
Node Material (BI Cycles) [bad result]
Node Texture [bad result]

The blend file:

Thanks for you hard work!
Best wishes!

Event Timeline

Danyang Yi (nirenyang) raised the priority of this task from to Needs Triage by Developer.
Danyang Yi (nirenyang) updated the task description. (Show Details)
Danyang Yi (nirenyang) set Type to Bug.

What do you expect when you use fully typed-out paths in the expressions (i.e. things like "bpy.data.<...blah blah blah>.<property_name_at_last>")?!

  • There's no way for Blender to know that there are dependencies between properties when you do this
  • Be aware too that not all datablocks (notably textures and a few others) cannot be updated correctly due to dependency graph limitations. In those cases, drivers must live on the corresponding objects/materials or else they will not work correctly

Like aligorith said: Drivers in nodes are severely limited by the current depgraph. Another issue is that the graph editor relies a lot on context, which makes it difficult for some datablock drivers to be displayed correctly.

@Joshua Leung (aligorith): Not sure about the duplicate shader driver listing. Looks like this is caused by duplicate loop for materials here:
https://developer.blender.org/diffusion/B/browse/master/source/blender/editors/animation/anim_filter.c$1767

Assigned to you for deciding.

Lukas Toenne (lukastoenne) lowered the priority of this task from Needs Triage by Developer to Normal.Mar 8 2014, 8:57 AM
Joshua Leung (aligorith) closed this task as Resolved.Mar 9 2014, 7:23 AM

Closed by commit rBd219312d44d7.

Hi! @Joshua Leung (aligorith) @Lukas Toenne (lukastoenne)

I've been replaced "fully typed-out paths" into "sin(frame)" still don't working. especially in Texture node.
Hope we can remove this limited someday.

Thanks for you reply. Thanks for your great work!