Page MenuHome

Bevel vertex tool deletes edges.
Closed, ResolvedPublic

Description

System Information
Win 8.1 64, GT 750M, I7 3630qm

Blender Version
Broken: 2.70 RC1, Hash: 19f7f9a

Exact steps for others to reproduce the error

  1. Make a plane
  2. Delete one vertice
  3. Choose the corner vertice. Press bevel vertex shortcut. Edges get deleted.

Attached blender file for example of result.

Details

Type
Bug

Event Timeline

Vlad Mafteiu Scai (00Ghz) set Type to Bug.
Vlad Mafteiu Scai (00Ghz) created this task.
Vlad Mafteiu Scai (00Ghz) raised the priority of this task from to Needs Triage by Developer.

I can confirm this behaviour.

It happens in version 2.70 and it also happens in version 2.69

version 2.70 - hash b'25ad7b4'
build date: b'2014-03-08', b'18:04:00'
platform: 'Windows:64bit'

Bastien Montagne (mont29) raised the priority of this task from Confirmed, Low to Normal.

As conceived and written, Bevel was intended only to work on cases where faces are present. For edge bevel, each beveled edge needs to have exactly two adjacent faces. For vertex bevel, initially it was only going to do vertices completely surrounded by faces, but at some point I made it work for outside corner vertices (but still with a face inside). The case in your example is one where there is no face at all. I need to either disable this case or write some special purpose code. Disabling would be easier. Another example: make a grid, delete faces only, and then try to do vertex bevel on any vertex.

https://www.youtube.com/watch?v=t_2nAXhGuqw

See here. It would be nice if you could do something like this both on vertex and curves. It would make making pipes so much easier instead of trying various workarounds.

Yes, thanks for that. I can see the utility.

Now to take it one step further would be nice to have some options like in the bridge tool. Not always pipes have a perfect corner.

Howard Trickey (howardt) closed this task as Resolved.May 16 2014, 4:34 PM