Bevel modifier. Сombination Segment and Profile creates a bulge.
Closed, ArchivedPublic

Description

System Information
Windows 8.1 x64
GForce GTX 560

Blender Version
Broken: 2.7 2d4de27

Sorry for my English, I use the Google translator.
I loved the new features Bevel modifier, use it for hardsurfece modeling.
But I ran into a problem on surfaces, which are at an angle, this modifier creates a bulge.
For example, if you add the number of segments to 4, and set equal to 1 Profile


Details

Type
Bug

Related Objects

Axel (AxelMening) updated the task description. (Show Details)
Axel (AxelMening) raised the priority of this task from to Needs Triage.
Axel (AxelMening) added a project: Modifiers.
Axel (AxelMening) set Type to Bug.

Don't really know if this could be considered a bug, but I can confirm it. Seems to work fine on the default cube, but rotate one of the faces or bevel and edge (in edit mode) and it'll have those bulges

Bastien Montagne (mont29) triaged this task as Normal priority.Mar 18 2014, 3:55 PM

Yes, I know about this. It is hard to get the profile=1 case to work right using the general purpose code for profiles. I special cased orthogonal corners, but really need to make a whole different code for this. So currently I call it working as intended, but a TODO to improve this (also to make the profile=0 case work, which also requires special case code).

Howard Trickey (howardt) closed this task as Archived.Mar 18 2014, 4:10 PM