Page MenuHome

Extruding makes reversed normals. Align/flip normals does not fix issue.
Closed, InvalidPublic

Description

System Information
I7 3630qm, 8GB RAM, 750M GT 2GB, Win 8.1 64

Blender Version
Broken: (example: 2.70 RC1 19f7f9a)
Worked: 2.69

Short description of error

Polys get wrong normals when extruded. There seems to be no exact order for this to happen. Sometimes it works fine. Sometimes is so bad that half of the polys are right half are wrong. Using align normals does not fix the issue. It seems to align them opposite of the camera view or object exterior so to speak. Other times it keeps some in one direction, others in opposite direction, just flips them around.
Exact steps for others to reproduce the error

  1. Make a plane from top view
  2. Delete 1 vertice
  3. Extrude on z-azis but cancel movement. Move extruded selection around and you will see that normals are in wrong direction(or try until buf occurs).

Details

Type
Bug

Event Timeline

Vlad Mafteiu Scai (00Ghz) set Type to Bug.
Vlad Mafteiu Scai (00Ghz) created this task.
Vlad Mafteiu Scai (00Ghz) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

I cannot find any issue with normals, following your given steps… Pleas attach a file demonstrating the issue.

Here.

Normals are reversed when they shouldn't be.

I do not see the problem… just flip them (after having selected the whole mesh, obviously), and issue is gone.

No you don't get it. This happens a lot in other extrusions as well. It is annoying to flip every time. And as I said sometimes it doesn't even work at all. Some normals stay inside, some outside in the same selection.

It is definitely a bug that never happened in 2.69

I’m sorry, but I tried extruding following your steps, and could not reproduce this… Normals are always consistent here, as far as I can tell… So what we need is a file *just before the extrusion* where we just have to extrude to reproduce the issue you describe.

Ok.

Let me provide the steps again because I missed something.

  1. Go to top view
  2. Add a plane
  3. Edit mode
  4. Delete top right vertice
  5. Press E to extrude. Press Z to lock axis. Press right mouse button to cancel transform but not the extrusion.
  6. Now with the active selection from the extrusion scale inwards.(Here the normals start to be inverse)
  7. With scale done, select all and extrude again on Z-axis.
  8. Now if you followed everything once you get back to perspective mode you can see the normals are reversed even if they shouldn't be. Sometimes as I said with more complex selections only parts of them get inversed and align normals only flips each one around maintaining the issue.

The file is the same I uploaded, you can use that. Also it is very important you stay in top view(or left,right etc but didn't test with those) at all times and follow steps exactly otherwise bug won't happen.

I followed exactly those steps in both 2.70 and 2.69, in the former at least both normals are in the same dir, in 2.69 I get opposed (mixed inwards/outwards) normals…

Anyway, I do not see a bug here, in that kind of operation there is no real way to chose a right normal, it merely depends from the order in which faces use vertices…

Assigning to Campbell to get its advice, just in case.

that might be the case, but yet again sometimes in the same object with more complex selection this thing causes some normals to be inwards some outwards. Using align or flip normals won't do any good since it just reverses each individual normal.

Let me give you an example. Let's say you got an Object with A, B, C, D, E as all connected polys and will be using 0 for inwards normal, and 1 for outwards normal

What happens sometimes that you get A,B,C, as 1 and D and E as 0. Let's now align normals as you suggested to fix the issue. Result? A,B,C = 0, D,E = 1
Obviously flip will just get back to original values.

Now as I see it this is a bug, not something that should be happening at all. What I should get is A,B,C,D,E = 0 or 1 . All of them, not some.

Ok. Another issue with normals and this time ain't from top view.

Although I am using the latest build from graphical.org

Anyway steps:

  1. Add cube in perspective
  2. Edit mode
  3. Delete all
  4. Add Circle(not curve)
  5. Set it to 16 points(not sure if it matters but for the sake of replicating exactly)
  6. Select all. Extrude on Z-Axis.
  7. Normals reversed....again....

I tried that last one with the circle within EDIT.

Depending on which direction along the Z-axis you extrude (positive or negative) you get a different direction of the normals, either all pointing in or else all pointing out.

Bastien Montagne (mont29) closed this task as Invalid.

Talked with @Campbell Barton (campbellbarton) about this one, he confirmed me it’s not a bug. Yes, a flat face has a normal in a direction. Yes, a flat face being non-closed volume (actually, not volume at all), it does not have an “inside” or an “outside”. Yes, when you extrude, normals of org selection are kept, which can lead to inwards normals in some cases…

This is not a bug, and not a regression. Thanks for the report, but will close it now.