Page MenuHome

bevel bug
Closed, ResolvedPublic

Description

blender-2.70-8f1a6e2-win64-vc12

Event Timeline

lopata (lopataasdf) set Type to Bug.
lopata (lopataasdf) created this task.
lopata (lopataasdf) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Cannot reproduce this bug with current trunk, please try with a build from http://builder.blender.org/download

Also always please specify minimal steps to redo the issue (from your "no bevel" file, I simply hit ctrl-B, and wheel to increase number of edges, everything looks good to me...).

Windows 7 Professional 64-bit
ASUS nVidia GeForce GTX 760 2GB GDDR5 DirectCU Mini
Blender 2.70 hash - 8f1a6e2

I can confirm this behavior on my system:

lopataasdf has posted the images of how the bevel function is going wrong.

In this case, when more than one bevel segment is used, the profile setting is not being taken into account on every edge line passing through the profiled area.

This same problem can also be seen in the Blender 2.69 bevel function. There is no profile setting there, but the curve of the edges passing through the beveled area is also not always correct.

But it is latest version from http://builder.blender.org/download... Try to increase profile like "with bevel.png" screenshot

Ah, yes, indeed, can reproduce it now…

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Confirmed, Medium.Mar 14 2014, 3:33 PM

hallo, i use the latest build blender-2.70-8f1a6e2-win64 and i get this workout. i use angle and depth. i hope, you meant the bevel modifier.

@Gabriel (taxishop) - Thanks for the input, but...

The problem refers to the direct-action bevel command in edit (Ctrl-B) rather than the bevel modifier.

It seems that in my case, when the parameter "Profile" is changed, some edges moving along the axis Z, though they should move in the XY-plane only

outside edge is displaced up

anyway i reccomend you to use the bevel as a modifier+weight, so you can control, which part/vertex or edge should be beveled and how much. i never use the standard bevel option and actually its unnecessary.

bevel operation and bevel modifier use same code

I see what you are talking about. I need to investigate further to see if this is working as intended or whether there is a bug here. I think there is probably a bug that can be fixed.

Howard Trickey (howardt) closed this task as Resolved.Jun 10 2014, 5:33 PM

I think I fixed this with commit rB84767a29f18de674692968c822b5847db7fac4e9 but am not sure whether this bug is complaining about more than one problem. I'm closing this for now, feel free to reopen if there are remaining problem(s).

Filip Sauer (cdog) reopened this task as Open.

Howardt, I can still reproduce the bug mentioned in the first post in today's build. That means edge loops which are close to each other still don't follow curvature and go straight. Just try a multisegment bevel on an edge loop.

The problem here is that you have edges totally in a plane (both the two edges to be beveled, and the two cross-edges on either side), and you want the multisegment bevel to be curved. I know that in this case, where they are running beside other edges that curve (because they aren't all in the same plane), it looks like a mistake. But there are other cases where making them curve can look wrong. So not clear what to do here.

I can't imagine a situation where I wouldn't want them to curve, but if you say so :) Maybe a checkbox then?

Here's a situation where making the cross-edges curved is not obviously the right thing to do. On the left is the edge to be beveled. In the middle is the current behavior. On the right is the result of an exploratory hack to recognize "being flat in a plane" as a special case and making them curve. (The outside edges don't curve because that's even more of a special case in the code that would have to be changed separately. Is the curved image always better and should I continue down this path? On issue could be that it is fragiley adapted to a special case, and making small changes in geometry could cause big flips in behavior. This could be the start of a long path of special cases to get this right...

The behaviour I would like is in the following image. Which means curved inside and outside edges included. The current behaviour really doesn't behave like a multisegment bevel. I could get the same with 1 segment bevel and then add loopcuts. So I think it's definitely worth continuing this path.

I agree. Curved all the way looks better but there should be an option to disable outside/inside curvature just in case.

@Howard Trickey (howardt), so what's going on with this? Is it fixed or a Todo or a valid, un-fixed bug? ;)

I have a branch that partially fixes this, but it is not working correctly everywhere, yet, and is too big a change to put in the close to the next release. I continue to work in the branch and hopefully will commit the change after the release.