Page MenuHome

Extreme Viewport slowdown in textured mode.
Closed, ResolvedPublic

Description

System Information
Windows 7 64bit
16 GB RAM, 8 x 3.1 GHz
512 MB AMD Radeon HD 6450

Blender Version
Broken: (2.70 19e627c)
Worked: (2.69)

Short description of error
In the newest Blender version I opened up a small scene with ~20 textures and many low poly objects.
Scene Information: 77 Objects, 3 Lamps, 4636 Verts, 4627 Faces and 7910 Tris, Mem: 147M
Everything works fine with the Solid display method, but when I switch to Textured (GLSL/Multitexture or Textured Solid or Textured Shadeless) it is slows down and it becomes impossible to work with. It does not crash.
In the previous version of Blender I had no problems with that scene.

Happens with MipMaps on/off and Antialising on/off (yes, I restarted Blender :) )

Exact steps for others to reproduce the error
Create a scene with a lot of textured objects and switch to textured mode.

Details

Type
Bug

Event Timeline

Philip Holzmann (Foaly) raised the priority of this task from to Needs Triage by Developer.
Philip Holzmann (Foaly) updated the task description. (Show Details)
Philip Holzmann (Foaly) set Type to Bug.

Hi, can´t reproduce it on my system.
I think we need a test file, reduce your file as much as possible and upload your file somewhere.

Opensuse 13.1/64
Intel i5 3770K
GTX 760
GTX 560Ti 448 Cores
Driver 331.49

Cheers, mib.

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Mar 21 2014, 10:22 AM

Please always attach .blend file which demonstrates the issue.

Also try going to User Preferences -> System and bump Memory Cache Limit setting there up to some bigger value and see whether it affects the performance.

Philip Holzmann (Foaly) closed this task as Resolved.Mar 21 2014, 1:48 PM
Philip Holzmann (Foaly) claimed this task.

Increasing the Memory Cache Limit solves the problem :)
Thanks.

I thought this value only affects video editing.