Page MenuHome

Blur in compositor produces artifacts
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card
Win 7 64bit, ATI Radeon HD 5700 series

Blender Version
Broken: official 2.70, but was present in older builds too

Short description of error
Certain values of blur produce artifacts.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps
Just render the attached file and see the borders of the blurred area where it gets sharply cropped. This only happens with some values of blur. Also visible on attached image.

Details

Type
Bug

Event Timeline

Filip Sauer (cdog) raised the priority of this task from to Needs Triage by Developer.
Filip Sauer (cdog) updated the task description. (Show Details)
Filip Sauer (cdog) set Type to Bug.
Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Normal.Mar 21 2014, 9:47 AM

@Jeroen Bakker (jbakker) assigning to you, seems to be combination of opencl and maybe area-of-interested once more ...

NOTE: You may have to bump up the brightness on this image, i couldn't see the error at first.

I believe that the artifacts that cdog is referring to are more clearly seen in the attached rework of his image.

I bumped the gamma from 1.00 up to something like 1.85 and there is clearly some 'garbage' on the edges of the blurred cube.

Yes, that's it. Sorry - I guess my screen is too bright, so I could see it well :)
I wonder, though, if the part where it gets narrower should be there at all (when blurring in X direction only). I would expect the correct result to look like this.

Yeah, confirmed as well. Interestingly it only happens with 256x256. If I set chunks to anything else. for example 32x32, it looks fine.

The issue also happens when the chunks are on different size:
for chunks 64x64 the bug happens when the X is set lower than 64
etc.
so will check the tile dependacy of the fast gaussian blur

Jeroen Bakker (jbakker) closed this task as Resolved.Mar 26 2014, 9:17 PM

Fixed in d9557d01bd2f724bc8995c916f91d66ef85d2faa

"The fast gaussian blur is not an accurate formula. When deciding
which tiles are selected for input there was always a constant for correcting

the accuracy.

It seems that the constant was not enough and has been adjusted. (2 => 3)."

Strange enough this was issue was not been raised before. There might be other 'settings' that this issue still happens. If so we need to increase the value again.