Page MenuHome

Graph Editor - keyframe tension arms will not scale
Closed, DuplicatePublic

Description

Windows 7 Pro 64-bit
Intel Core i7-4770K CPU @ 3.50GHz
ASUS nVidia GeForce GTX 760 2GB GDDR5 DirectCU Mini

Worked: 2.69 r60995

Broken: 2.70 19e627c

Problem: Selected keyframes will not respond to scale (S) command.

Select any keyframe center anchor point on motion curve. Tension arms refuse to scale.
Individually selected tension arms will respond to scale command.

See attached blend file.

Details

Type
Bug

Event Timeline

Ignatz (ignatz) added a project: BF Blender.
Ignatz (ignatz) set Type to Bug.
Ignatz (ignatz) added a subscriber: Ignatz (ignatz).
Ignatz (ignatz) created this task.
Ignatz (ignatz) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) triaged this task as Normal priority.

Quite sure this is not a bug (scaling of control points is not designed to work the way you expect it), but assigning to Joshua for confirmation. :)

IMO it's a bit of a regression due to a commit Campbell made during bcon4 IIRC. (https://developer.blender.org/rB6cc5bdc99e63b05248f132833bfe0259c2a27923)

The problem is that we have a bit of a tradeoff here.
IIRC, Campbell's commit disabled scaling and/or rotating so that handles don't go crazy when you simply select everything and scale up/down a whole cluster of stuff. The alternative is what used to be in place, which intended to allow this sort of modification when you've got just a single keyframe + its handles selected (AND with the "individual centers" pivot mode active, as in this file).

Gentlemen, do let me point out that this behavior is not only applicable to a single selected keyframe.

If the pivot form 'Individual Centers' is selected then this is what is needed to scale the tension on multiple selections at one time.

Oh, and I forgot to mention this...

This functionality is indispensible when it is necessary to vary the tension on multiple, equal curves at once.

A particular example of this would be when varying the tension a keyframe of an object's scale animation - equally on X, Y and Z - to constantly maintain the object's proportions.

Joshua Leung (aligorith) closed this task as a duplicate.Mar 27 2014, 11:04 PM

✘ Merged into T39457.